summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-04-01 08:01:08 +0100
committerJustin Lecher <jlec@gentoo.org>2018-04-01 21:51:32 +0100
commit7c70a7c78b4cdf958e038bb170e46adc5b308aef (patch)
tree9223dc64b71472daf08ea8b1c567a3ab6a2d828c /sys-fs/aufs4
parentsci-visualization/paraview: version bump to 5.4.1 (diff)
downloadgentoo-7c70a7c78b4cdf958e038bb170e46adc5b308aef.tar.gz
gentoo-7c70a7c78b4cdf958e038bb170e46adc5b308aef.tar.bz2
gentoo-7c70a7c78b4cdf958e038bb170e46adc5b308aef.zip
sys-fs/aufs4: Bump to latest release
Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'sys-fs/aufs4')
-rw-r--r--sys-fs/aufs4/Manifest1
-rw-r--r--sys-fs/aufs4/aufs4-0_pre20180312.ebuild184
2 files changed, 185 insertions, 0 deletions
diff --git a/sys-fs/aufs4/Manifest b/sys-fs/aufs4/Manifest
index 305539c56be1..d3fb157ba6f7 100644
--- a/sys-fs/aufs4/Manifest
+++ b/sys-fs/aufs4/Manifest
@@ -11,3 +11,4 @@ DIST aufs4-standalone-0_pre20170612.tar.xz 2017248 BLAKE2B 40fa98545d6ddd3685f9c
DIST aufs4-standalone-0_pre20171002.tar.xz 2265048 BLAKE2B ae68812c547411bebd7e169e3bfa840536386a3cfdd876473f167372ec716c7df620329438c9024b185bb302d2053df5ded7026342a166d68187dc756a6e9560 SHA512 ee9d0e48fba6671fe4c5d3f533956c3eb0c6caa45fc4074be94f4427d84a5446cd4dc9f3ebf27fb56e697b24172ddd14a61c246f0414ebce8e372c204dfbb150
DIST aufs4-standalone-0_pre20171106.tar.xz 2351120 BLAKE2B e29209475da3c39188eb9ec88bf91cd50d7d882fdd234e32e28741b500aa85427e98a23528a297f35562f81dc4f8e4932783917644b2eda0b4f2744ac15b700e SHA512 9a8c6f59b737133e423613365bb46fd197f05a93d459b6206a70807ffaa6763b7095b2f4780deb6e7882a2b464aaa185cf1760febbf3a674e8d0cf71c7ba72ee
DIST aufs4-standalone-0_pre20180219.tar.xz 2496676 BLAKE2B 61015534f74f9f2398b79643d9528c59f0069fefae3bf9382eea1f31db69fe22195ce8a929e2c25285b41fdc070d7f255effb6d408d3997d61dd83beda544452 SHA512 b667be0c2c2b9bcef66f81839364fa56871c2577b9b2389f0464b669a1404fd68928522bb5b3eb4c114b21b6e86201fb50eeaf167d194de187f305ebc0b75cb7
+DIST aufs4-standalone-0_pre20180312.tar.xz 2521856 BLAKE2B e226a6ba530fe9423d1671cee59501445cbc70419801420f6c5eb8c5fd3af3cce9301d9d32042ea8c4c704a847b4f46bd006c397871f7c9ee5dcb4e92c3ce7e9 SHA512 60e1dfb703706f21928645c51d1a4138187e7ea44d86ca5f2ee8a991a910974bc514340237a7c51397d658ca56e2cf32cfcf374eb8e060073266042e5ee42cee
diff --git a/sys-fs/aufs4/aufs4-0_pre20180312.ebuild b/sys-fs/aufs4/aufs4-0_pre20180312.ebuild
new file mode 100644
index 000000000000..1917bdd71b81
--- /dev/null
+++ b/sys-fs/aufs4/aufs4-0_pre20180312.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic linux-info linux-mod multilib readme.gentoo-r1 toolchain-funcs
+
+AUFS_VERSION="${PV%%_p*}"
+# highest branch version
+PATCH_MAX_VER=13
+# highest supported version
+KERN_MAX_VER=16
+# lowest supported version
+KERN_MIN_VER=0
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/aufs4-standalone-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc fuse hfs inotify kernel-patch nfs pax_kernel ramfs"
+
+DEPEND="
+ dev-util/patchutils
+ dev-vcs/git"
+RDEPEND="
+ sys-fs/aufs-util
+ !sys-fs/aufs
+ !sys-fs/aufs2
+ !sys-fs/aufs3"
+
+S="${WORKDIR}"/${PN}-standalone
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ CONFIG_CHECK+=" !AUFS_FS"
+ use inotify && CONFIG_CHECK+=" ~FSNOTIFY"
+ use nfs && CONFIG_CHECK+=" EXPORTFS"
+ use fuse && CONFIG_CHECK+=" ~FUSE_FS"
+ use hfs && CONFIG_CHECK+=" ~HFSPLUS_FS"
+ use pax_kernel && CONFIG_CHECK+=" PAX" \
+ && ERROR_PAX="Please use hardened sources"
+
+ # this is needed so merging a binpkg ${PN} is
+ # possible w/out a kernel unpacked on the system
+ [[ -n "$PKG_SETUP_HAS_BEEN_RAN" ]] && return
+
+ get_version
+ kernel_is lt 4 ${KERN_MIN_VER} 0 && \
+ die "the kernel version isn't supported by upstream anymore. Please upgrade."
+ kernel_is gt 4 ${KERN_MAX_VER} 99 && die "kernel too new"
+
+ linux-mod_pkg_setup
+
+ if [[ "${KV_MINOR}" -gt "${PATCH_MAX_VER}" ]]; then
+ PATCH_BRANCH="x-rcN"
+ elif [[ "${KV_MINOR}" == "1" ]] && [[ "${KV_PATCH}" -ge "13" ]]; then
+ PATCH_BRANCH="${KV_MINOR}".13+
+ else
+ PATCH_BRANCH="${KV_MINOR}"
+ fi
+
+ case ${KV_EXTRA} in
+ "")
+ elog "It seems you are using vanilla-sources with aufs4"
+ elog "Please use sys-kernel/aufs-sources with USE=vanilla"
+ elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade"
+ ;;
+ "-gentoo")
+ elog "It seems you are using gentoo-sources with aufs4"
+ elog "Please use sys-kernel/aufs-sources"
+ elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade"
+ ;;
+ esac
+
+ pushd "${T}" &> /dev/null || die
+ unpack ${A}
+
+ cd ${PN}-standalone || die
+
+ local module_branch=origin/${PN}.${PATCH_BRANCH}
+
+ einfo "Using ${module_branch} as patch source"
+ git checkout -q -b local-${PN}.${PATCH_BRANCH} ${module_branch} || die
+
+ combinediff \
+ ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch
+ combinediff \
+ "${T}"/combined-1.patch ${PN}-mmap.patch \
+ > ${PN}-standalone-base-mmap-combined.patch
+
+ if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < ${PN}-standalone-base-mmap-combined.patch > /dev/null ); then
+ if use kernel-patch; then
+ cd ${KV_DIR}
+ ewarn "Patching your kernel..."
+ patch \
+ --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} \
+ < "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch \
+ > /dev/null
+ epatch "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
+ ewarn "You need to compile your kernel with the applied patch"
+ ewarn "to be able to load and use the aufs kernel module"
+ else
+ eerror "You need to apply a patch to your kernel to compile and run the ${PN} module"
+ eerror "Either enable the kernel-patch useflag to do it with this ebuild"
+ eerror "or apply "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch by hand"
+ die "missing kernel patch, please apply it first"
+ fi
+ fi
+
+ popd &> /dev/null
+ export PKG_SETUP_HAS_BEEN_RAN=1
+}
+
+set_config() {
+ for option in $*; do
+ grep -q "^CONFIG_AUFS_${option} =" config.mk || \
+ die "${option} is not a valid config option"
+ sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
+ done
+}
+
+src_prepare() {
+ local module_branch=origin/${PN}.${PATCH_BRANCH}
+
+ einfo "Using for module creation branch ${module_branch}"
+ git checkout -q -b local-gentoo ${module_branch} || die
+
+ # All config options to off
+ sed "s:= y:=:g" -i config.mk || die
+
+ set_config RDU BRANCH_MAX_127 SBILIST
+
+ use debug && set_config DEBUG
+ use fuse && set_config BR_FUSE POLL
+ use hfs && set_config BR_HFSPLUS
+ use inotify && set_config HNOTIFY HFSNOTIFY
+ use nfs && set_config EXPORT
+ use nfs && ( use amd64 || use ppc64 ) && set_config INO_T_64
+ use ramfs && set_config BR_RAMFS
+
+ use pax_kernel && epatch "${FILESDIR}"/pax-4.patch
+
+ sed \
+ -e "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" \
+ -i Makefile || die
+
+ eapply_user
+}
+
+src_compile() {
+ local ARCH=x86
+
+ emake \
+ CC=$(tc-getCC) \
+ LD=$(tc-getLD) \
+ LDFLAGS="$(raw-ldflags)" \
+ ARCH=$(tc-arch-kernel) \
+ CONFIG_AUFS_FS=m \
+ KDIR="${KV_OUT_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ use doc && dodoc -r Documentation
+
+ use kernel-patch || \
+ doins "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
+
+ dodoc \
+ Documentation/filesystems/aufs/README \
+ "${T}"/${PN}-standalone/{aufs4-loopback,vfs-ino,tmpfs-idr}.patch
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ linux-mod_pkg_postinst
+}