summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-07-18 11:20:18 +0800
committerJason Zaman <perfinion@gentoo.org>2016-07-18 11:20:18 +0800
commit559d0ad230ebc50693b817a4b0766fb457f0d8f9 (patch)
treeda81b1f6d416cca6d2d209fa26f692ffed5e61fb /sys-fs/cachefilesd
parentsys-fs/cachefilesd: Remove unused from FILESDIR (diff)
downloadgentoo-559d0ad230ebc50693b817a4b0766fb457f0d8f9.tar.gz
gentoo-559d0ad230ebc50693b817a4b0766fb457f0d8f9.tar.bz2
gentoo-559d0ad230ebc50693b817a4b0766fb457f0d8f9.zip
sys-fs/cachefilesd: Bump to 0.10.9
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-fs/cachefilesd')
-rw-r--r--sys-fs/cachefilesd/Manifest1
-rw-r--r--sys-fs/cachefilesd/cachefilesd-0.10.9.ebuild58
-rw-r--r--sys-fs/cachefilesd/files/cachefilesd-0.10.9-makefile.patch19
3 files changed, 78 insertions, 0 deletions
diff --git a/sys-fs/cachefilesd/Manifest b/sys-fs/cachefilesd/Manifest
index f6edcf0f5961..b5fa6c4acc13 100644
--- a/sys-fs/cachefilesd/Manifest
+++ b/sys-fs/cachefilesd/Manifest
@@ -1 +1,2 @@
DIST cachefilesd-0.10.5.tar 112640 SHA256 125ea4f6aef4bf8e936a7cc747b59e074537a8aed74cd1bab3f05d7fbc47287f SHA512 996e47de40cff4d2c0d265689ef3a33aee6ef0d0432a03d7428133c091e77b0e099bd1346b5638bf2d9df6bb47bce519491b420d5916a3211c4e04e158ad92e8 WHIRLPOOL fad173739c307629ffef091a0cad890ee9bb3b133471de1fe9bb43cc06ee46a051fdb97262f9380a8133fb49cd87b9cbd3ee71205867046bd361f890c2645f1e
+DIST cachefilesd-0.10.9.tar.bz2 26555 SHA256 c897ec6704615f26de3ddc20ff30a191ce995cb8973d2cde88b4b28c1a1e6bca SHA512 06ab444a7df8ec37c15bc03554510f4acbb453e0730277f036abc5d61f9e377d90d9387dd5237ea481b95b1bf097b5992adce90ce971fe29760cc4c0d3c9cf34 WHIRLPOOL 97a398ebaecfdc5f16317607ef4a17a4518969930f2ca436eebeaca445a763eaef03cd648e8a21b0c9bebe8a25c072108c227162185b90e666bb41580cd5883a
diff --git a/sys-fs/cachefilesd/cachefilesd-0.10.9.ebuild b/sys-fs/cachefilesd/cachefilesd-0.10.9.ebuild
new file mode 100644
index 000000000000..ce6dd71851b1
--- /dev/null
+++ b/sys-fs/cachefilesd/cachefilesd-0.10.9.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="Provides a caching directory on an already mounted filesystem"
+HOMEPAGE="https://people.redhat.com/~dhowells/fscache/"
+SRC_URI="https://people.redhat.com/~dhowells/fscache/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-cachefilesd )"
+DEPEND=""
+
+src_prepare() {
+ eapply_user
+ eapply "${FILESDIR}"/${PN}-0.10.9-makefile.patch
+ if ! use selinux; then
+ sed -e '/^secctx/s:^:#:g' -i cachefilesd.conf || die
+ fi
+
+ tc-export CC
+ append-flags -fpie
+}
+
+src_install() {
+ default
+
+ if use selinux; then
+ insinto /usr/share/doc/${P}
+ doins -r selinux
+ fi
+
+ dodoc howto.txt
+
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+ newinitd "${FILESDIR}"/${PN}-3.init ${PN}
+
+ systemd_dounit ${PN}.service
+ systemd_newtmpfilesd "${FILESDIR}"/${PN}-tmpfiles.d ${PN}.conf
+}
+
+pkg_postinst() {
+ [[ -d /var/cache/fscache ]] && return
+ elog "Before CacheFiles can be used, a directory for local storage"
+ elog "must be created. The default configuration of /etc/cachefilesd.conf"
+ elog "uses /var/cache/fscache. The filesystem mounted there must support"
+ elog "extended attributes (mount -o user_xattr)."
+ echo ""
+ elog "Once that is taken care of, start the daemon, add -o ...,fsc"
+ elog "to the mount options of your network mounts, and let it fly!"
+}
diff --git a/sys-fs/cachefilesd/files/cachefilesd-0.10.9-makefile.patch b/sys-fs/cachefilesd/files/cachefilesd-0.10.9-makefile.patch
new file mode 100644
index 000000000000..276eff35a1c0
--- /dev/null
+++ b/sys-fs/cachefilesd/files/cachefilesd-0.10.9-makefile.patch
@@ -0,0 +1,19 @@
+--- cachefilesd-0.10.9/Makefile.old 2016-07-18 11:12:38.467106807 +0800
++++ cachefilesd-0.10.9/Makefile 2016-07-18 11:13:59.937770347 +0800
+@@ -1,4 +1,3 @@
+-CFLAGS := -g -O2 -Wall -Wsign-compare
+ INSTALL := install
+ DESTDIR :=
+ ETCDIR := /etc
+@@ -40,7 +39,10 @@
+ ###############################################################################
+ all: cachefilesd
+
+-cachefilesd: cachefilesd.c Makefile
++cachefilesd.o: cachefilesd.c
++ $(CC) $(CFLAGS) -c $<
++
++cachefilesd: cachefilesd.o
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
+
+ ###############################################################################