summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-09-05 20:11:03 +1200
committerJoonas Niilola <juippis@gentoo.org>2020-09-06 08:55:16 +0300
commitf97937256788b43034a553f1c6b033199f9cab88 (patch)
treef7c57014e54f7a1275748a9e855db0ea19936618 /sys-fs/compsize
parentsys-fs/compsize: bump to 1.3 (diff)
downloadgentoo-f97937256788b43034a553f1c6b033199f9cab88.tar.gz
gentoo-f97937256788b43034a553f1c6b033199f9cab88.tar.bz2
gentoo-f97937256788b43034a553f1c6b033199f9cab88.zip
sys-fs/compsize: 9999 update + EAPI 7
Package-Manager: Portage-3.0.4-r1, Repoman-3.0.1 Signed-off-by: Theo Anderson <telans@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/17113 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs/compsize')
-rw-r--r--sys-fs/compsize/compsize-9999.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/sys-fs/compsize/compsize-9999.ebuild b/sys-fs/compsize/compsize-9999.ebuild
index ad73046823bd..3144e142c1e2 100644
--- a/sys-fs/compsize/compsize-9999.ebuild
+++ b/sys-fs/compsize/compsize-9999.ebuild
@@ -1,41 +1,43 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit flag-o-matic
-DESCRIPTION="Utility to find btrfs compression ratio"
+DESCRIPTION="Utility to find btrfs compression type/ratio on a file or set of files"
HOMEPAGE="https://github.com/kilobyte/compsize"
if [[ ${PV} = 9999 ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/kilobyte/compsize"
+ EGIT_REPO_URI="https://github.com/kilobyte/compsize.git"
else
- KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/kilobyte/compsize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-2+"
-SLOT=0
+IUSE="debug"
+SLOT="0"
-RDEPEND=""
DEPEND="sys-fs/btrfs-progs"
src_prepare() {
- eapply_user
- # Don't try to install a gzipped manfile during make install, instead
- # use doman in src_install to ensure that PORTAGE_COMPRESS is used
- sed -i $'/^\tgzip /d' Makefile || die
+ default
+ # Don't try to install a gzipped manfile during emake install
+ sed -i -e $'s/\.gz//' -e $'s/gzip.*/install \-Dm755 \$\< \$\@/' Makefile || die
+ # sys-fs/compsize > 1.3 removes '/usr' from install paths in Makefile
+ sed -i $'s/(PREFIX)/(PREFIX)\/usr/' Makefile || die
}
src_configure() {
# Used in upstream Makefile, but clobbered by portage's CFLAGS
append-cflags -Wall -std=gnu90
+ use debug && append-cflags -DDEBUG -g
default
}
src_install() {
- emake PREFIX="${ED%/}" install
- doman compsize.8
- einstalldocs
+ emake PREFIX="${D}" install
+ dodoc "README.md"
}