summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-03-07 22:49:35 +0100
committerMatt Turner <mattst88@gentoo.org>2019-03-18 11:27:13 -0700
commitef75fc19d32a532430f50d1b732a385d1dbde991 (patch)
tree14db9f2467c2fdb8900f1439eb2486347400e0a6 /sys-fs/cryptmount
parentnet-im/openmittsu: Remove old. (diff)
downloadgentoo-ef75fc19d32a532430f50d1b732a385d1dbde991.tar.gz
gentoo-ef75fc19d32a532430f50d1b732a385d1dbde991.tar.bz2
gentoo-ef75fc19d32a532430f50d1b732a385d1dbde991.zip
sys-fs/cryptmount: bump to version 5.3.1
Closes: https://bugs.gentoo.org/628734 Closes: https://bugs.gentoo.org/641176 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/11289 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-fs/cryptmount')
-rw-r--r--sys-fs/cryptmount/Manifest1
-rw-r--r--sys-fs/cryptmount/cryptmount-5.3.1.ebuild75
-rw-r--r--sys-fs/cryptmount/metadata.xml45
3 files changed, 114 insertions, 7 deletions
diff --git a/sys-fs/cryptmount/Manifest b/sys-fs/cryptmount/Manifest
index de2cf8aaaf23..0bb0a1c73bdd 100644
--- a/sys-fs/cryptmount/Manifest
+++ b/sys-fs/cryptmount/Manifest
@@ -1 +1,2 @@
DIST cryptmount-5.2.2.tar.gz 743638 BLAKE2B fdcf0ec18904bd847d905a1241c0e4e9c825b9c73f2cab0406426d56d22a0ef4d26701d9955b4f7975cc1cedcd650758cd4aebb29805e6cf8a8c05ef9202b8b7 SHA512 e8767728c49b7f8dc4f777778d5a9d1b912ea2c4c5363dbb5035a208aa1bd1f2565ce12a0666d75e9ee677bde04029082d20c22cf46a216f5e87a4adf7093572
+DIST cryptmount-5.3.1.tar.gz 748020 BLAKE2B 63c66717ed8a8ede983894564576d26720a571b47bd33f3cd160596d831c017c7239b307eb9fb8112c6a51f91799117a47392675f9fe53c0286ada84887d528e SHA512 c4bfb7a2bd2f672dfed014d3a4b1feaa4d20237f9b658ea981a0a054e83ad4d0282089a006ceb769ee05e0cf6ecd004c97b48d69973ed630330e77bf13925680
diff --git a/sys-fs/cryptmount/cryptmount-5.3.1.ebuild b/sys-fs/cryptmount/cryptmount-5.3.1.ebuild
new file mode 100644
index 000000000000..2562091101a1
--- /dev/null
+++ b/sys-fs/cryptmount/cryptmount-5.3.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="A utility for management and user-mode mounting of encrypted filesystems"
+HOMEPAGE="http://cryptmount.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="argv0switch cswap fsck +gcrypt +largefile mount +nls +luks +openssl selinux systemd udev"
+REQUIRED_USE="
+ luks? ( gcrypt )
+ openssl? ( gcrypt )
+"
+
+RDEPEND="
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ nls? ( sys-devel/gettext )
+ luks? ( sys-fs/cryptsetup )
+ openssl? ( dev-libs/openssl:0= )
+ systemd? ( sys-apps/systemd )
+ udev? ( virtual/udev )
+ virtual/libiconv
+ virtual/libintl
+"
+
+DEPEND="
+ ${RDEPEND}
+ sys-kernel/linux-headers
+"
+
+DOCS=( "AUTHORS" "ChangeLog" "NEWS" "README" "README.OpenSSL" "README.sshfs" "RELNOTES" "ToDo" )
+
+CONFIG_CHECK="BLK_DEV_DM"
+ERROR_BLK_DEV_DM="
+ Please enable Device Mapper support in your kernel config
+ -> Device Drivers
+ -> Multiple devices driver support (RAID and LVM)
+ -> Multiple devices driver support (RAID and LVM)
+ <*>/<M> Device mapper support
+"
+
+src_prepare() {
+ default
+
+ # Since SELinux is hardcoded, remove it on disabled SELinux profile
+ if ! use selinux; then
+ sed -e '/selinux/d' -i dmutils.c || die
+ fi
+}
+
+src_configure() {
+ local myeconf=(
+ --disable-rpath
+ $(use_enable argv0switch)
+ $(use_enable cswap)
+ $(use_enable fsck)
+ $(use_with gcrypt libgcrypt)
+ $(use_enable largefile)
+ $(use_enable mount delegation)
+ $(use_enable nls)
+ $(use_enable luks)
+ $(use_enable openssl openssl-compat)
+ $(use_with systemd)
+ $(use_enable udev libudev)
+
+ )
+
+ econf "${myeconf[@]}"
+}
diff --git a/sys-fs/cryptmount/metadata.xml b/sys-fs/cryptmount/metadata.xml
index ccc363c97a28..8468e05cbbe7 100644
--- a/sys-fs/cryptmount/metadata.xml
+++ b/sys-fs/cryptmount/metadata.xml
@@ -1,11 +1,42 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>isav@alzari.pw</email>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- </maintainer>
- <longdescription>A utility for management and user-mode mounting of encrypted filesystems</longdescription>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Cryptmount was written to make it as easy for ordinary users
+ to access encrypted filesystems on-demand using the newer devmapper
+ mechansism as it was to use the older, now deprecated, cryptoloop methods.
+ This offers the following advantages:
+
+ Access to improved functionality in the kernel
+ Transparent support for filesystems stored on either raw disk partitions or loopback files
+ Separate encryption of filesystem access keys, allowing access passwords to be changed without re-encrypting the entire filesystem
+ Storing multiple encrypted filesystems within a single disk partition, using a designated subset of blocks for each
+ Rarely used filesystems do not need to be mounted at system startup
+ Un-mounting of each filesystem is locked so that this can only be performed by the user that mounted it, or the superuser
+ Encrypted filesystems compatible with cryptsetup
+ Encrypted access-keys can be chosen to be compatible with openssl, or managed via libgcrypt, or (for 2.0 release-series) built-in SHA1/Blowfish ciphers
+ Support for encrypted swap partitions (superuser only)
+ Support for setting up encrypted filesystems or crypto-swap at system boot-up
+ </longdescription>
+ <use>
+ <flag name="argv0switch">Default action given by progname.</flag>
+ <flag name="cswap">Enable support for encrypted swap.</flag>
+ <flag name="fsck">Check filesystems before mounting.</flag>
+ <flag name="gcrypt">Support libgcrypt-encryption of keys.</flag>
+ <flag name="largefile">Enable support for large files.</flag>
+ <flag name="mount">Use systemd mount/umount for operations.</flag>
+ <flag name="luks">Enable key management via LUKS</flag>
+ <flag name="openssl">Support openssl-encryption of keys.</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://sourceforge.net/p/cryptmount/bugs/</bugs-to>
+ <remote-id type="sourceforge">cryptmount</remote-id>
+ </upstream>
</pkgmetadata>