summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-03-08 17:55:36 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-03-08 17:55:36 +0100
commit30d4947f33a0520c41792f0ba1ed6e093510ebb2 (patch)
tree186d294bee832d18c3ba255248a2e996e362571e /sys-fs/ctmg/ctmg-1.2.ebuild
parentsys-fs/ctmg: stable (diff)
downloadgentoo-30d4947f33a0520c41792f0ba1ed6e093510ebb2.tar.gz
gentoo-30d4947f33a0520c41792f0ba1ed6e093510ebb2.tar.bz2
gentoo-30d4947f33a0520c41792f0ba1ed6e093510ebb2.zip
sys-fs/ctmg: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'sys-fs/ctmg/ctmg-1.2.ebuild')
-rw-r--r--sys-fs/ctmg/ctmg-1.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-fs/ctmg/ctmg-1.2.ebuild b/sys-fs/ctmg/ctmg-1.2.ebuild
new file mode 100644
index 000000000000..95a4470bda9a
--- /dev/null
+++ b/sys-fs/ctmg/ctmg-1.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Simple wrapper around cryptsetup for encrypted containers"
+HOMEPAGE="http://git.zx2c4.com/ctmg/about/"
+SRC_URI="http://git.zx2c4.com/${PN}/snapshot/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm ~arm64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-fs/cryptsetup sys-apps/util-linux sys-fs/e2fsprogs sys-apps/coreutils app-admin/sudo"
+
+src_compile() { :; }
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}