summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-09-11 22:56:32 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-09-11 22:57:57 +0200
commit618e049e476daac3ab697f41ee7edd23b5012ddd (patch)
treeeb803d1be19aa956296e9e811750674f9edcef1d /sys-fs/ddrescue/ddrescue-1.20.ebuild
parentsys-apps/help2man: Removed old. (diff)
downloadgentoo-618e049e476daac3ab697f41ee7edd23b5012ddd.tar.gz
gentoo-618e049e476daac3ab697f41ee7edd23b5012ddd.tar.bz2
gentoo-618e049e476daac3ab697f41ee7edd23b5012ddd.zip
sys-fs/ddrescue: Bump to version 1.20
Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/ddrescue/ddrescue-1.20.ebuild')
-rw-r--r--sys-fs/ddrescue/ddrescue-1.20.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-fs/ddrescue/ddrescue-1.20.ebuild b/sys-fs/ddrescue/ddrescue-1.20.ebuild
new file mode 100644
index 000000000000..638980d95b7a
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.20.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic unpacker
+
+DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
+HOMEPAGE="https://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="static"
+
+DEPEND="$(unpacker_src_uri_depends)"
+RDEPEND=""
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # not a normal configure script
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ --enable-linux \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man
+ dodoc ChangeLog README NEWS AUTHORS
+}