summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-28 20:44:52 -0400
committerMike Frysinger <vapier@gentoo.org>2016-03-28 20:44:59 -0400
commit90d3156ebcade1197b21c37b5aaaaaf9fc9238eb (patch)
treedf39fd15b55fce4236e1c98f5b8266fa1ab8b98c /sys-fs/e2fsprogs
parentsys-libs/e2fsprogs-libs & sys-fs/e2fsprogs: drop old 1.42.12 versions (diff)
downloadgentoo-90d3156ebcade1197b21c37b5aaaaaf9fc9238eb.tar.gz
gentoo-90d3156ebcade1197b21c37b5aaaaaf9fc9238eb.tar.bz2
gentoo-90d3156ebcade1197b21c37b5aaaaaf9fc9238eb.zip
sys-fs/e2fsprogs: fix build w/newer glibc #577946
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.42.13.ebuild1
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.42.13-sysmacros.patch74
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.42.13.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.42.13.ebuild
index abe315f4bbee..34a40471fd6c 100644
--- a/sys-fs/e2fsprogs/e2fsprogs-1.42.13.ebuild
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.42.13.ebuild
@@ -39,6 +39,7 @@ src_prepare() {
fi
epatch "${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch #516854
epatch "${FILESDIR}"/${PN}-1.42.13-subst-perms.patch #550986
+ epatch "${FILESDIR}"/${PN}-1.42.13-sysmacros.patch
# blargh ... trick e2fsprogs into using e2fsprogs-libs
rm -rf doc
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.42.13-sysmacros.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.42.13-sysmacros.patch
new file mode 100644
index 000000000000..2e4c4e0564c2
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.42.13-sysmacros.patch
@@ -0,0 +1,74 @@
+From 13a12900148e6b778d8532ca76ff38edcec5a45f Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 28 Mar 2016 20:31:33 -0400
+Subject: [PATCH e2fsprogs] include sys/sysmacros.h as needed
+
+The minor/major/makedev macros are not entirely standard. glibc has had
+the definitions in sys/sysmacros.h since the start, and wants to move away
+from always defining them implicitly via sys/types.h (as this pollutes the
+namespace in violation of POSIX). Other C libraries have already dropped
+them. Since the configure script already checks for this header, use that
+to pull in the header in files that use these macros.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+
+--- a/lib/blkid/devname.c
++++ b/lib/blkid/devname.c
+@@ -36,6 +36,9 @@
+ #if HAVE_SYS_MKDEV_H
+ #include <sys/mkdev.h>
+ #endif
++#ifdef HAVE_SYS_SYSMACROS_H
++#include <sys/sysmacros.h>
++#endif
+ #include <time.h>
+
+ #include "blkidP.h"
+--- a/lib/blkid/devno.c
++++ b/lib/blkid/devno.c
+@@ -31,6 +31,9 @@
+ #if HAVE_SYS_MKDEV_H
+ #include <sys/mkdev.h>
+ #endif
++#ifdef HAVE_SYS_SYSMACROS_H
++#include <sys/sysmacros.h>
++#endif
+
+ #include "blkidP.h"
+
+--- a/lib/ext2fs/finddev.c
++++ b/lib/ext2fs/finddev.c
+@@ -31,6 +31,9 @@
+ #if HAVE_SYS_MKDEV_H
+ #include <sys/mkdev.h>
+ #endif
++#ifdef HAVE_SYS_SYSMACROS_H
++#include <sys/sysmacros.h>
++#endif
+
+ #include "ext2_fs.h"
+ #include "ext2fs.h"
+--- a/lib/ext2fs/ismounted.c
++++ b/lib/ext2fs/ismounted.c
+@@ -49,6 +49,9 @@
+ #endif /* HAVE_GETMNTINFO */
+ #include <string.h>
+ #include <sys/stat.h>
++#ifdef HAVE_SYS_SYSMACROS_H
++#include <sys/sysmacros.h>
++#endif
+
+ #include "ext2_fs.h"
+ #include "ext2fs.h"
+--- a/misc/mk_hugefiles.c
++++ b/misc/mk_hugefiles.c
+@@ -35,6 +35,9 @@ extern int optind;
+ #include <sys/ioctl.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#ifdef HAVE_SYS_SYSMACROS_H
++#include <sys/sysmacros.h>
++#endif
+ #include <libgen.h>
+ #include <limits.h>
+ #include <blkid/blkid.h>