summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-03-29 08:21:20 -0500
committerBen Kohler <bkohler@gentoo.org>2021-03-29 08:49:24 -0500
commit1e97662aa3f0fa3d80eb879395ce7984bdfe72c5 (patch)
tree891d832cf82bfbb882308a26565171f7a9747de8 /sys-fs/fatcat
parentnet-dns/openresolv: clean up old m-n tag in metadata.xml (diff)
downloadgentoo-1e97662aa3f0fa3d80eb879395ce7984bdfe72c5.tar.gz
gentoo-1e97662aa3f0fa3d80eb879395ce7984bdfe72c5.tar.bz2
gentoo-1e97662aa3f0fa3d80eb879395ce7984bdfe72c5.zip
sys-fs/fatcat: switch to cmake eclass
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-fs/fatcat')
-rw-r--r--sys-fs/fatcat/fatcat-1.1.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-fs/fatcat/fatcat-1.1.0-r2.ebuild b/sys-fs/fatcat/fatcat-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..1b785a18b115
--- /dev/null
+++ b/sys-fs/fatcat/fatcat-1.1.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="FAT filesystems explore, extract, repair, and forensic tool"
+HOMEPAGE="https://github.com/Gregwar/fatcat"
+SRC_URI="https://github.com/Gregwar/fatcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!elibc_glibc? ( sys-libs/argp-standalone )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/fatcat-include-getopt.patch )
+
+src_install() {
+ cmake_src_install
+ doman man/${PN}.1
+ dodoc docs/*.md
+}