summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-07-27 19:22:27 +0200
committerJeroen Roovers <jer@gentoo.org>2018-07-27 19:23:13 +0200
commitc095a8110e5a0588acef4a95652fc2591800044e (patch)
tree859c98dfbc83a3a727a735b7702cc2e67f19c5ce /sys-fs/fatresize/fatresize-1.0.4.ebuild
parentapp-misc/lirc: Add dependency on dev-python/setuptools (diff)
downloadgentoo-c095a8110e5a0588acef4a95652fc2591800044e.tar.gz
gentoo-c095a8110e5a0588acef4a95652fc2591800044e.tar.bz2
gentoo-c095a8110e5a0588acef4a95652fc2591800044e.zip
sys-fs/fatresize: Initial commit (bug #632582).
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'sys-fs/fatresize/fatresize-1.0.4.ebuild')
-rw-r--r--sys-fs/fatresize/fatresize-1.0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-fs/fatresize/fatresize-1.0.4.ebuild b/sys-fs/fatresize/fatresize-1.0.4.ebuild
new file mode 100644
index 000000000000..cfdd713b6f02
--- /dev/null
+++ b/sys-fs/fatresize/fatresize-1.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Resize FAT partitions using libparted"
+HOMEPAGE="https://github.com/ya-mouse/fatresize"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ sys-block/parted
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-version.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}