summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucian Poston <lucianposton@pm.me>2018-08-01 16:11:50 -0700
committerMichał Górny <mgorny@gentoo.org>2018-08-22 22:32:39 +0200
commit1dfcc35bd4fa8159f8824cbfa745896841626818 (patch)
treef2739577437689ec92f105c0edc91feabfdfdb40 /sys-fs/fragview/fragview-0.1.1.ebuild
parentapp-misc/imgurbash2: New package (diff)
downloadgentoo-1dfcc35bd4fa8159f8824cbfa745896841626818.tar.gz
gentoo-1dfcc35bd4fa8159f8824cbfa745896841626818.tar.bz2
gentoo-1dfcc35bd4fa8159f8824cbfa745896841626818.zip
sys-fs/fragview: New package
Closes: https://bugs.gentoo.org/662614 Closes: https://github.com/gentoo/gentoo/pull/9417 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-fs/fragview/fragview-0.1.1.ebuild')
-rw-r--r--sys-fs/fragview/fragview-0.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/fragview/fragview-0.1.1.ebuild b/sys-fs/fragview/fragview-0.1.1.ebuild
new file mode 100644
index 000000000000..5e531deaaae0
--- /dev/null
+++ b/sys-fs/fragview/fragview-0.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/i-rinat/fragview.git"
+else
+ SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Disk fragmentation visualizer based on FIEMAP and FIBMAP ioctls"
+HOMEPAGE="https://github.com/i-rinat/fragview"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-db/sqlite:3
+ dev-libs/boost:=
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-linking.patch" )