summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/fuse-exfat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/fuse-exfat')
-rw-r--r--sys-fs/fuse-exfat/Manifest2
-rw-r--r--sys-fs/fuse-exfat/files/99-exfat.rules1
-rw-r--r--sys-fs/fuse-exfat/fuse-exfat-1.0.1.ebuild38
-rw-r--r--sys-fs/fuse-exfat/fuse-exfat-1.1.0.ebuild35
-rw-r--r--sys-fs/fuse-exfat/metadata.xml12
5 files changed, 88 insertions, 0 deletions
diff --git a/sys-fs/fuse-exfat/Manifest b/sys-fs/fuse-exfat/Manifest
new file mode 100644
index 000000000000..1b0a539c8195
--- /dev/null
+++ b/sys-fs/fuse-exfat/Manifest
@@ -0,0 +1,2 @@
+DIST fuse-exfat-1.0.1.tar.gz 39627 SHA256 12ac1ba1b7d4343bef64e7898176705a41cfe3b5a7a179e28549d242e2854758 SHA512 e444031e7a6b999b3014ced255447bdfe4586b16970f36393706433262ca0cbd17911d6ca7af3465871f3136bdd9c8be2ec85f0dd124d670b240829093d341f6 WHIRLPOOL 521e1bc9356e2fcef7afc7720f5a4b017aa908f58af1537bc243ebfdfb6ba41dcba3cdb8d9e5b526e2333d93fffe4d0ffc5b29b9025387088f5b486393e5bf7c
+DIST fuse-exfat-1.1.0.tar.gz 36677 SHA256 198c520e417e955dc5c08687c278e63eefa56719da4452aa4a605be0327f953e SHA512 60280687c9adea3955fd85f003482e9d40163924837e5dcac4205c2bd02318c8ea280103a509213e83a04d390507f15dfe3cd3ecc03e9b90abcf4cef7e830398 WHIRLPOOL 86c029c13287b9b7b0b4d7798f7eef9dfad37bc05b5cbb836cd71539f78b0bcfeeffd7d2d35c3b4c55ca259b8ed1f0d6ea68bad23b3304c36775c20717b38a35
diff --git a/sys-fs/fuse-exfat/files/99-exfat.rules b/sys-fs/fuse-exfat/files/99-exfat.rules
new file mode 100644
index 000000000000..914e9d576f13
--- /dev/null
+++ b/sys-fs/fuse-exfat/files/99-exfat.rules
@@ -0,0 +1 @@
+ENV{ID_FS_TYPE}=="exfat", ENV{ID_FS_TYPE}="exfat-fuse"
diff --git a/sys-fs/fuse-exfat/fuse-exfat-1.0.1.ebuild b/sys-fs/fuse-exfat/fuse-exfat-1.0.1.ebuild
new file mode 100644
index 000000000000..67e41571bdc7
--- /dev/null
+++ b/sys-fs/fuse-exfat/fuse-exfat-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit scons-utils toolchain-funcs #udev
+
+DESCRIPTION="exFAT filesystem FUSE module"
+HOMEPAGE="http://code.google.com/p/exfat/"
+SRC_URI="http://exfat.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc64 ~s390 ~sh ~sparc x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sys-fs/fuse"
+DEPEND=${RDEPEND}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ escons CCFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dosbin fuse/mount.exfat-fuse
+ dosym mount.exfat-fuse /usr/sbin/mount.exfat
+
+ doman */*.8
+ dodoc ChangeLog
+
+ #This shouldn't really be required. Comment it out for now.
+ #udev_dorules "${FILESDIR}"/99-exfat.rules
+}
+
+pkg_postinst() {
+ elog "You can emerge sys-fs/exfat-utils for dump, label, mkfs and fsck utilities."
+}
diff --git a/sys-fs/fuse-exfat/fuse-exfat-1.1.0.ebuild b/sys-fs/fuse-exfat/fuse-exfat-1.1.0.ebuild
new file mode 100644
index 000000000000..06bb9feafc95
--- /dev/null
+++ b/sys-fs/fuse-exfat/fuse-exfat-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit scons-utils toolchain-funcs
+
+DESCRIPTION="exFAT filesystem FUSE module"
+HOMEPAGE="http://code.google.com/p/exfat/"
+SRC_URI="http://docs.google.com/uc?export=download&id=0B7CLI-REKbE3VTdaa0EzTkhYdU0 -> ${P}.tar.gz"
+
+LICENSE="GPL-2+" # COPYING is GPL-2 but ChangeLog says "Relicensed the project from GPLv3+ to GPLv2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sys-fs/fuse"
+DEPEND=${RDEPEND}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ escons CCFLAGS="${CFLAGS} -Wall -std=c99"
+}
+
+src_install() {
+ dosbin fuse/mount.exfat-fuse
+ dosym mount.exfat-fuse /usr/sbin/mount.exfat
+
+ doman */*.8
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ elog "You can emerge sys-fs/exfat-utils for dump, label, mkfs and fsck utilities."
+}
diff --git a/sys-fs/fuse-exfat/metadata.xml b/sys-fs/fuse-exfat/metadata.xml
new file mode 100644
index 000000000000..7b05b18e4457
--- /dev/null
+++ b/sys-fs/fuse-exfat/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">exfat</remote-id>
+ </upstream>
+</pkgmetadata>