summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-16 21:26:35 +0100
committerSam James <sam@gentoo.org>2021-04-21 20:01:14 +0100
commitbbd8ed6239abdfb1b350c3129d0762dc96294a4c (patch)
tree21a3585466cec8a8d4ba6122a12e80fa81406243 /sys-fs/fuse
parentsys-fs/fuse: use BDEPEND for virtual/pkgconfig (diff)
downloadgentoo-bbd8ed6239abdfb1b350c3129d0762dc96294a4c.tar.gz
gentoo-bbd8ed6239abdfb1b350c3129d0762dc96294a4c.tar.bz2
gentoo-bbd8ed6239abdfb1b350c3129d0762dc96294a4c.zip
sys-fs/fuse: flag-o-matic--, toolchain-funcs-- where possible
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/fuse-2.9.9-r1.ebuild3
-rw-r--r--sys-fs/fuse/fuse-3.10.1.ebuild6
-rw-r--r--sys-fs/fuse/fuse-3.10.2.ebuild4
-rw-r--r--sys-fs/fuse/fuse-3.9.1.ebuild4
4 files changed, 9 insertions, 8 deletions
diff --git a/sys-fs/fuse/fuse-2.9.9-r1.ebuild b/sys-fs/fuse/fuse-2.9.9-r1.ebuild
index b971294e9291..aaf77a867a81 100644
--- a/sys-fs/fuse/fuse-2.9.9-r1.ebuild
+++ b/sys-fs/fuse/fuse-2.9.9-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic libtool linux-info udev toolchain-funcs
+
+inherit flag-o-matic libtool linux-info udev
DESCRIPTION="An interface for filesystems implemented in userspace"
HOMEPAGE="https://github.com/libfuse/libfuse"
diff --git a/sys-fs/fuse/fuse-3.10.1.ebuild b/sys-fs/fuse/fuse-3.10.1.ebuild
index 8025c8d65060..9296c09d0fe1 100644
--- a/sys-fs/fuse/fuse-3.10.1.ebuild
+++ b/sys-fs/fuse/fuse-3.10.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit meson multilib-minimal flag-o-matic udev python-any-r1
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit meson multilib-minimal udev python-any-r1
DESCRIPTION="An interface for filesystems implemented in userspace"
HOMEPAGE="https://github.com/libfuse/libfuse"
diff --git a/sys-fs/fuse/fuse-3.10.2.ebuild b/sys-fs/fuse/fuse-3.10.2.ebuild
index f4e0fdbf39e2..5af77ebc394a 100644
--- a/sys-fs/fuse/fuse-3.10.2.ebuild
+++ b/sys-fs/fuse/fuse-3.10.2.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit meson multilib-minimal flag-o-matic udev python-any-r1
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit meson multilib-minimal udev python-any-r1
DESCRIPTION="An interface for filesystems implemented in userspace"
HOMEPAGE="https://github.com/libfuse/libfuse"
diff --git a/sys-fs/fuse/fuse-3.9.1.ebuild b/sys-fs/fuse/fuse-3.9.1.ebuild
index 57795826c8b6..20ece00766a1 100644
--- a/sys-fs/fuse/fuse-3.9.1.ebuild
+++ b/sys-fs/fuse/fuse-3.9.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8} )
inherit meson multilib-minimal flag-o-matic udev python-any-r1
DESCRIPTION="An interface for filesystems implemented in userspace"