summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <mscardovi@icloud.com>2022-12-21 11:55:39 +0100
committerMatt Turner <mattst88@gentoo.org>2022-12-21 10:13:04 -0500
commit6ba2defa91fc468416c013f3e0a9bceb5ac419a7 (patch)
tree1824e6f48b90bcf191b8ade61d30138d30b957d9 /sys-fs/genfstab
parentdev-libs/libgusb: Version bump to 0.4.3 (diff)
downloadgentoo-6ba2defa91fc468416c013f3e0a9bceb5ac419a7.tar.gz
gentoo-6ba2defa91fc468416c013f3e0a9bceb5ac419a7.tar.bz2
gentoo-6ba2defa91fc468416c013f3e0a9bceb5ac419a7.zip
sys-fs/genfstab: revbump to r1, add missing awk requirement, enable test
Signed-off-by: Marco Scardovi <mscardovi@icloud.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-fs/genfstab')
-rw-r--r--sys-fs/genfstab/genfstab-28-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-fs/genfstab/genfstab-28-r1.ebuild b/sys-fs/genfstab/genfstab-28-r1.ebuild
new file mode 100644
index 000000000000..a80ba66d79d3
--- /dev/null
+++ b/sys-fs/genfstab/genfstab-28-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Genfstab - generate output suitable for addition to an fstab file"
+HOMEPAGE="https://github.com/scardracs/genfstab https://man.archlinux.org/man/genfstab.8"
+SRC_URI="https://github.com/scardracs/genfstab/releases/download/${PV}/${P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-alternatives/awk
+ app-text/asciidoc
+"
+
+src_test() {
+ emake check
+}