summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/jfsutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/jfsutils')
-rw-r--r--sys-fs/jfsutils/Manifest1
-rw-r--r--sys-fs/jfsutils/files/jfsutils-1.1.15-linux-headers.patch12
-rw-r--r--sys-fs/jfsutils/jfsutils-1.1.15.ebuild38
-rw-r--r--sys-fs/jfsutils/metadata.xml9
4 files changed, 60 insertions, 0 deletions
diff --git a/sys-fs/jfsutils/Manifest b/sys-fs/jfsutils/Manifest
new file mode 100644
index 000000000000..a80227235735
--- /dev/null
+++ b/sys-fs/jfsutils/Manifest
@@ -0,0 +1 @@
+DIST jfsutils-1.1.15.tar.gz 539148 SHA256 244a15f64015ce3ea17e49bdf6e1a0fb4f9af92b82fa9e05aa64cb30b5f07a4d SHA512 fa8ba7f4997471da3e6ea7239564f3395046222cfbb2b10e37b24ad0bd107b7eadbb51ce328d89d193034360b4035ca5e0e5b0b416a74483d7a2c0a2b9c65858 WHIRLPOOL 8a62c037601999f616041250e06adc10fceb48fc80b319003383ac08b2e1fbb2aaaca781848be2845d6e99f05d1d7a884f9af89e2a6236d64cc4387be02222e8
diff --git a/sys-fs/jfsutils/files/jfsutils-1.1.15-linux-headers.patch b/sys-fs/jfsutils/files/jfsutils-1.1.15-linux-headers.patch
new file mode 100644
index 000000000000..b3570107c57d
--- /dev/null
+++ b/sys-fs/jfsutils/files/jfsutils-1.1.15-linux-headers.patch
@@ -0,0 +1,12 @@
+Index: jfsutils-1.1.15/libfs/devices.h
+===================================================================
+--- jfsutils-1.1.15.orig/libfs/devices.h
++++ jfsutils-1.1.15/libfs/devices.h
+@@ -42,6 +42,7 @@
+
+ struct stat;
+
++#include <stdint.h>
+ int ujfs_get_dev_size(FILE *, int64_t * size);
+ int ujfs_rw_diskblocks(FILE *, int64_t, int32_t, void *, int32_t);
+ int ujfs_flush_dev(FILE *);
diff --git a/sys-fs/jfsutils/jfsutils-1.1.15.ebuild b/sys-fs/jfsutils/jfsutils-1.1.15.ebuild
new file mode 100644
index 000000000000..7080e0df034a
--- /dev/null
+++ b/sys-fs/jfsutils/jfsutils-1.1.15.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="IBM's Journaling Filesystem (JFS) Utilities"
+HOMEPAGE="http://jfs.sourceforge.net/"
+SRC_URI="http://jfs.sourceforge.net/project/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh ~sparc x86"
+IUSE="static"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-linux-headers.patch
+}
+
+src_configure() {
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ use static && append-ldflags -static
+ econf --sbindir=/sbin
+}
+
+src_install () {
+ default
+
+ rm -f "${ED}"/sbin/{mkfs,fsck}.jfs || die
+ dosym /sbin/jfs_mkfs /sbin/mkfs.jfs
+ dosym /sbin/jfs_fsck /sbin/fsck.jfs
+}
diff --git a/sys-fs/jfsutils/metadata.xml b/sys-fs/jfsutils/metadata.xml
new file mode 100644
index 000000000000..67e7fd658cef
--- /dev/null
+++ b/sys-fs/jfsutils/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <herd>kernel-misc</herd>
+ <longdescription>
+ Utilities for working with IBM's journaled file system
+ </longdescription>
+</pkgmetadata>