summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/loop-aes/loop-aes-3.7b.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/loop-aes/loop-aes-3.7b.ebuild')
-rw-r--r--sys-fs/loop-aes/loop-aes-3.7b.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/sys-fs/loop-aes/loop-aes-3.7b.ebuild b/sys-fs/loop-aes/loop-aes-3.7b.ebuild
new file mode 100644
index 000000000000..9fc6e7234e7e
--- /dev/null
+++ b/sys-fs/loop-aes/loop-aes-3.7b.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit linux-mod
+
+MY_P="${PN/aes/AES}-v${PV}"
+
+DESCRIPTION="Linux kernel module to encrypt local file systems and disk partitions with AES cipher"
+HOMEPAGE="http://loop-aes.sourceforge.net/loop-AES.README"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~hppa ~ppc ~sparc x86"
+IUSE="cpu_flags_x86_aes extra-ciphers keyscrub cpu_flags_x86_padlock"
+
+DEPEND="app-crypt/loop-aes-losetup"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ CONFIG_CHECK="!BLK_DEV_LOOP"
+ MODULE_NAMES="loop(block::tmp-d-kbuild)"
+ BUILD_TARGETS="all"
+
+ BUILD_PARAMS=" \
+ V=1 \
+ LINUX_SOURCE=\"${KERNEL_DIR}\" \
+ KBUILD_OUTPUT=\"${KBUILD_OUTPUT}\" \
+ USE_KBUILD=y MODINST=n RUNDM=n"
+ use cpu_flags_x86_aes && BUILD_PARAMS="${BUILD_PARAMS} INTELAES=y"
+ use keyscrub && BUILD_PARAMS="${BUILD_PARAMS} KEYSCRUB=y"
+ use cpu_flags_x86_padlock && BUILD_PARAMS="${BUILD_PARAMS} PADLOCK=y"
+
+ if use extra-ciphers; then
+ MODULE_NAMES="${MODULE_NAMES}
+ loop_blowfish(block::tmp-d-kbuild)
+ loop_serpent(block::tmp-d-kbuild)
+ loop_twofish(block::tmp-d-kbuild)"
+ BUILD_PARAMS="${BUILD_PARAMS} EXTRA_CIPHERS=y"
+ fi
+}
+
+src_prepare() {
+ sed -e 's/make/$(MAKE)/g' -i Makefile || die "sed failed"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README
+ dobin loop-aes-keygen
+ doman loop-aes-keygen.1
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo
+ einfo "For more instructions take a look at examples in README at:"
+ einfo "'${EPREFIX}/usr/share/doc/${PF}'"
+ einfo
+ einfo "If you have a newer Intel processor (i5, i7), and you use AES"
+ einfo "you may want to consider using the aes-ni use flag. It will"
+ einfo "use your processors native AES instructions giving quite a speed"
+ einfo "increase."
+ einfo
+
+ ewarn
+ ewarn "Please consider using loop-aes-losetup package instead of"
+ ewarn "util-linux[loop-aes], it will enable all loop-aes services"
+ ewarn "without patching util-linux package"
+ ewarn
+ ewarn "In future only loop-aes-losetup will be available in portage"
+ ewarn
+}