summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-12-12 11:03:50 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-12-12 12:57:30 +0100
commit78da4d4e35e4e6e3b04ecc330c0265a4311d0b77 (patch)
treea407fe2429d112529fdee777044f3a785861f4bf /sys-fs/lvm2
parentmedia-libs/mlt: Switch 6.10.0 to ruby24 (diff)
downloadgentoo-78da4d4e35e4e6e3b04ecc330c0265a4311d0b77.tar.gz
gentoo-78da4d4e35e4e6e3b04ecc330c0265a4311d0b77.tar.bz2
gentoo-78da4d4e35e4e6e3b04ecc330c0265a4311d0b77.zip
sys-fs/lvm2: Minor ebuild improvements.
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/lvm2')
-rw-r--r--sys-fs/lvm2/lvm2-2.02.183.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-fs/lvm2/lvm2-2.02.183.ebuild b/sys-fs/lvm2/lvm2-2.02.183.ebuild
index ea67d28a6d8c..6ea92b0ac768 100644
--- a/sys-fs/lvm2/lvm2-2.02.183.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.183.ebuild
@@ -197,12 +197,12 @@ src_compile() {
}
src_install() {
- local inst
- INSTALL_TARGETS="install install_tmpfiles_configuration"
+ local inst INSTALL_TARGETS
+ INSTALL_TARGETS=( install install_tmpfiles_configuration )
# install systemd related files only when requested, bug #522430
- use systemd && INSTALL_TARGETS="${INSTALL_TARGETS} install_systemd_units install_systemd_generators"
- use device-mapper-only && INSTALL_TARGETS="install_device-mapper"
- for inst in ${INSTALL_TARGETS}; do
+ use systemd && INSTALL_TARGETS+=( install_systemd_units install_systemd_generators )
+ use device-mapper-only && INSTALL_TARGETS=( install_device-mapper )
+ for inst in ${INSTALL_TARGETS[@]}; do
emake DESTDIR="${D}" ${inst}
done