summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-24 12:06:20 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-24 12:06:20 +0200
commitabfedf55c98ff501e8c924646ea91ed315a0c71e (patch)
treece139d3d1a21158eb640741813680ac4fcf80d92 /sys-fs/lvm2
parentsys-fs/lvm2: Improvements for 2.03 series (diff)
downloadgentoo-abfedf55c98ff501e8c924646ea91ed315a0c71e.tar.gz
gentoo-abfedf55c98ff501e8c924646ea91ed315a0c71e.tar.bz2
gentoo-abfedf55c98ff501e8c924646ea91ed315a0c71e.zip
sys-fs/lvm2: use /bin/bash as CONFIG_SHELL
Closes: https://bugs.gentoo.org/682404 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/lvm2')
-rw-r--r--sys-fs/lvm2/lvm2-2.02.183.ebuild3
-rw-r--r--sys-fs/lvm2/lvm2-2.02.184-r4.ebuild3
-rw-r--r--sys-fs/lvm2/lvm2-2.02.185.ebuild3
-rw-r--r--sys-fs/lvm2/lvm2-2.03.05.ebuild3
4 files changed, 12 insertions, 0 deletions
diff --git a/sys-fs/lvm2/lvm2-2.02.183.ebuild b/sys-fs/lvm2/lvm2-2.02.183.ebuild
index 1b37eab4af34..595dd187372a 100644
--- a/sys-fs/lvm2/lvm2-2.02.183.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.183.ebuild
@@ -180,6 +180,9 @@ src_configure() {
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
CLDFLAGS="${LDFLAGS}"
)
+ # Hard-wire this to bash as some shells (dash) don't know
+ # "-o pipefail" #682404
+ CONFIG_SHELL="/bin/bash" \
econf "${myeconfargs[@]}"
}
diff --git a/sys-fs/lvm2/lvm2-2.02.184-r4.ebuild b/sys-fs/lvm2/lvm2-2.02.184-r4.ebuild
index 30771d99b7c7..bfe82c27d5d0 100644
--- a/sys-fs/lvm2/lvm2-2.02.184-r4.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.184-r4.ebuild
@@ -185,6 +185,9 @@ src_configure() {
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
CLDFLAGS="${LDFLAGS}"
)
+ # Hard-wire this to bash as some shells (dash) don't know
+ # "-o pipefail" #682404
+ CONFIG_SHELL="/bin/bash" \
econf "${myeconfargs[@]}"
}
diff --git a/sys-fs/lvm2/lvm2-2.02.185.ebuild b/sys-fs/lvm2/lvm2-2.02.185.ebuild
index 2912f4832990..812f84d2b656 100644
--- a/sys-fs/lvm2/lvm2-2.02.185.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.185.ebuild
@@ -188,6 +188,9 @@ src_configure() {
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
CLDFLAGS="${LDFLAGS}"
)
+ # Hard-wire this to bash as some shells (dash) don't know
+ # "-o pipefail" #682404
+ CONFIG_SHELL="/bin/bash" \
econf "${myeconfargs[@]}"
}
diff --git a/sys-fs/lvm2/lvm2-2.03.05.ebuild b/sys-fs/lvm2/lvm2-2.03.05.ebuild
index d4cb83b032c7..12b13a5e36e6 100644
--- a/sys-fs/lvm2/lvm2-2.03.05.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.05.ebuild
@@ -177,6 +177,9 @@ src_configure() {
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
CLDFLAGS="${LDFLAGS}"
)
+ # Hard-wire this to bash as some shells (dash) don't know
+ # "-o pipefail" #682404
+ CONFIG_SHELL="/bin/bash" \
econf "${myeconfargs[@]}"
}