summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-05-14 18:51:05 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-05-15 08:20:29 +0300
commit90b61eec7b3a7507c25d743cc6e769f9d116b05b (patch)
treed38e1a955929b5e8f5bb7e08828720ce6d91a2ac /sys-fs/lxcfs/lxcfs-4.0.3.ebuild
parentapp-emulation/lxc: bump to 4.0.1 (diff)
downloadgentoo-90b61eec7b3a7507c25d743cc6e769f9d116b05b.tar.gz
gentoo-90b61eec7b3a7507c25d743cc6e769f9d116b05b.tar.bz2
gentoo-90b61eec7b3a7507c25d743cc6e769f9d116b05b.zip
sys-fs/lxcfs: bump to 4.0.3
Closes: https://bugs.gentoo.org/698722 Closes: https://bugs.gentoo.org/712802 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs/lxcfs/lxcfs-4.0.3.ebuild')
-rw-r--r--sys-fs/lxcfs/lxcfs-4.0.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-fs/lxcfs/lxcfs-4.0.3.ebuild b/sys-fs/lxcfs/lxcfs-4.0.3.ebuild
new file mode 100644
index 000000000000..1e51a5673784
--- /dev/null
+++ b/sys-fs/lxcfs/lxcfs-4.0.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="FUSE filesystem for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/ https://github.com/lxc/lxcfs/"
+SRC_URI="https://github.com/lxc/lxcfs/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Omit all dbus. Upstream appears to require it because systemd, but
+# lxcfs makes no direct use of dbus.
+RDEPEND="
+ dev-libs/glib:2
+ sys-fs/fuse:0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/help2man"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+ ./bootstrap.sh || die "Failed to bootstrap configure files"
+}
+
+src_configure() {
+ # Without the localstatedir the filesystem isn't mounted correctly
+ econf --localstatedir=/var
+}
+
+src_test() {
+ emake tests
+ tests/main.sh || die "Tests failed"
+}
+
+src_install() {
+ default
+
+ dodir /var/lib/lxcfs
+ keepdir /var/lib/lxcfs
+
+ newconfd "${FILESDIR}"/lxcfs-4.0.0.confd lxcfs
+ newinitd "${FILESDIR}"/lxcfs-4.0.0.initd lxcfs
+ systemd_dounit config/init/systemd/lxcfs.service
+}