summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/mp3fs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/mp3fs')
-rw-r--r--sys-fs/mp3fs/Manifest2
-rw-r--r--sys-fs/mp3fs/metadata.xml11
-rw-r--r--sys-fs/mp3fs/mp3fs-0.32.ebuild24
-rw-r--r--sys-fs/mp3fs/mp3fs-0.91.ebuild21
4 files changed, 58 insertions, 0 deletions
diff --git a/sys-fs/mp3fs/Manifest b/sys-fs/mp3fs/Manifest
new file mode 100644
index 000000000000..fae4867da817
--- /dev/null
+++ b/sys-fs/mp3fs/Manifest
@@ -0,0 +1,2 @@
+DIST mp3fs-0.32.tar.gz 120579 SHA256 0b3d7064bf27b86a7f691684760f02126b5edab0108d65826c2a0f7f1a3eefd1 SHA512 826ad719198195d66fff5bbb4b9b6734b5f180f37ead11bf77ecf9dd7cc86e4e2243cdea78c029b3bb8757efb9f52143f84c979f07034b016147b6257d0c9980 WHIRLPOOL 318a9ad3187e443ae396df6bc52da1178371777f7d8720e97ab7ac0a0d9a5c919b52bd0f87ff7c4aa2ef324b0fcb74cd5582067674447997d612de3053c8c0db
+DIST mp3fs-0.91.tar.gz 357098 SHA256 a47b5e351b7660e6f535a3c5b489c5a8191209957f8c0b8d066a5c221e8ecf92 SHA512 9499566afbaf181acd9efb8a4d6253e288ab9be0c8b036b2993553d0d4f4692d7dbcf34ac03787d8dbbfc35b2cc29e1d78612933c428a908c9c48290fedb8681 WHIRLPOOL 7acf9bf3a89df397439c814dd8110558d9508942b76e337a0d776bfb906da6ae69e3ee1ce480210f993eae3f3a4e457880373241a21ade127e7b2f993020ffdc
diff --git a/sys-fs/mp3fs/metadata.xml b/sys-fs/mp3fs/metadata.xml
new file mode 100644
index 000000000000..19703855fdd0
--- /dev/null
+++ b/sys-fs/mp3fs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">khenriks/mp3fs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/mp3fs/mp3fs-0.32.ebuild b/sys-fs/mp3fs/mp3fs-0.32.ebuild
new file mode 100644
index 000000000000..e71056c4d0dd
--- /dev/null
+++ b/sys-fs/mp3fs/mp3fs-0.32.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="a read-only FUSE filesystem which transcodes FLAC audio files to MP3 when read"
+HOMEPAGE="http://khenriks.github.com/mp3fs/"
+SRC_URI="mirror://github/khenriks/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-fs/fuse
+ media-libs/libid3tag
+ media-libs/flac
+ media-sound/lame
+ media-libs/libogg"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README.rst
+}
diff --git a/sys-fs/mp3fs/mp3fs-0.91.ebuild b/sys-fs/mp3fs/mp3fs-0.91.ebuild
new file mode 100644
index 000000000000..a681935398fd
--- /dev/null
+++ b/sys-fs/mp3fs/mp3fs-0.91.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="a read-only FUSE filesystem which transcodes FLAC audio files to MP3 when read"
+HOMEPAGE="http://khenriks.github.com/mp3fs/"
+SRC_URI="https://github.com/khenriks/mp3fs/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-fs/fuse
+ media-libs/libid3tag
+ media-libs/flac
+ media-sound/lame
+ media-libs/libogg"
+RDEPEND="${DEPEND}"