summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-08 10:22:03 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-08 10:22:48 +0200
commit1d7e73a89036e628131b3a90a8229b003300fa16 (patch)
treec1cb9f28256d76f923b893fa864ba8de89e5def2 /sys-fs/multipath-tools
parentdev-python/jellyfish: Disable in-source builds (diff)
downloadgentoo-1d7e73a89036e628131b3a90a8229b003300fa16.tar.gz
gentoo-1d7e73a89036e628131b3a90a8229b003300fa16.tar.bz2
gentoo-1d7e73a89036e628131b3a90a8229b003300fa16.zip
sys-fs/multipath-tools: Bump to version 0.8.2
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/multipath-tools')
-rw-r--r--sys-fs/multipath-tools/Manifest1
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.8.2.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-fs/multipath-tools/Manifest b/sys-fs/multipath-tools/Manifest
index 4e8a400621de..7f7d1847e5eb 100644
--- a/sys-fs/multipath-tools/Manifest
+++ b/sys-fs/multipath-tools/Manifest
@@ -2,3 +2,4 @@ DIST multipath-tools-0.6.4.tar.gz 285448 BLAKE2B 1b63c4e712e682965c595ed988a6590
DIST multipath-tools-0.7.9.tar.gz 419377 BLAKE2B 29003b7ce2d673eb59d869e2165028654361ca31f49b8e810d90611db249a5183492959d3aef778b870df7c1d283004bda88f3cc6f760569247f1ccc61617379 SHA512 6b237f148c239938b9f46a1a8118fc070372d5f2cfe2021c26ad9ca15d37e8866390168b6a4f13adcc5538001354247e072559a0add33ce1fe8245ae64ed0a3c
DIST multipath-tools-0.8.0.tar.gz 447076 BLAKE2B 10a93a2654decd2377414188013d2141e34288fe119fa7c54047d95b825ef9ae64b20de1067d3f37a904b58be587997842f7a62088701fe1c1e6a078283b56e4 SHA512 8b6081109e535d0e392233bcedda930bc6d4b529ebe23bc45b276026311bc997e3cf8b39c1a86e4962c464faa69512202c0f6fb3d1f06c6445f8141853ad1bc4
DIST multipath-tools-0.8.1.tar.gz 447883 BLAKE2B c840ede03fd15763cd947a71596bf3a2e5935433d956208225f4fd6ed55074e2d9709f8b0e6c059a58d44b6649f52b3564d6651ea1af6186138357ba37f86b14 SHA512 1f87f974aace746ecac8af6ae330de16affe49cc89a5660b28be3b1c4a69f822da01042432176e64b5de6ad3a6568044954fdce8e3aa31e85611a595a4939947
+DIST multipath-tools-0.8.2.tar.gz 458879 BLAKE2B a5aae1c9b211c788b658cf53e1c966bb9dd39dbe3e81058d6c758ba11cfd77ebfbc9d70bfde5b41d00fb1d4fbf31f3d2e6d58c69179e8842b9f5b8e9edd0b755 SHA512 c809e652479a8b6b141fd69810dbba316d93368ec6cf1c57f479ccde50e3ccf0bebe1b62e9db4791135aec45a90761f9100635f0ffa4b175ce9c2d82ebcea5c9
diff --git a/sys-fs/multipath-tools/multipath-tools-0.8.2.ebuild b/sys-fs/multipath-tools/multipath-tools-0.8.2.ebuild
new file mode 100644
index 000000000000..fe7820dee263
--- /dev/null
+++ b/sys-fs/multipath-tools/multipath-tools-0.8.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit linux-info systemd toolchain-funcs udev vcs-snapshot toolchain-funcs
+
+DESCRIPTION="Device mapper target autoconfig"
+HOMEPAGE="http://christophe.varoqui.free.fr/"
+SRC_URI="https://git.opensvc.com/?p=multipath-tools/.git;a=snapshot;h=${PV};sf=tgz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="systemd rbd"
+
+RDEPEND="
+ dev-libs/json-c:=
+ dev-libs/libaio
+ dev-libs/userspace-rcu:=
+ >=sys-fs/lvm2-2.02.45
+ >=virtual/udev-171
+ sys-libs/readline:0=
+ rbd? ( sys-cluster/ceph )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+CONFIG_CHECK="~DM_MULTIPATH"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.7.5-respect-flags.patch )
+
+get_systemd_pv() {
+ use systemd && \
+ $(tc-getPKG_CONFIG) --modversion systemd
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # The upstream lacks any way to configure the build at present
+ # and ceph is a huge dependency, so we're using sed to make it
+ # optional until the upstream has a proper configure system
+ if ! use rbd ; then
+ sed \
+ -e "s/libcheckrbd.so/# libcheckrbd.so/" \
+ -e "s/-lrados//" \
+ -i libmultipath/checkers/Makefile \
+ || die
+ fi
+}
+
+src_compile() {
+ # LIBDM_API_FLUSH involves grepping files in /usr/include,
+ # so force the test to go the way we want #411337.
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDM_API_FLUSH=1 SYSTEMD="$(get_systemd_pv)"
+}
+
+src_install() {
+ dodir /sbin /usr/share/man/man{5,8}
+ emake \
+ DESTDIR="${D}" \
+ SYSTEMD=$(get_systemd_pv) \
+ unitdir="$(systemd_get_systemunitdir)" \
+ libudevdir='${prefix}'/"$(get_udevdir)" \
+ install
+
+ newinitd "${FILESDIR}"/rc-multipathd multipathd
+ newinitd "${FILESDIR}"/multipath.rc multipath
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "If you need multipath on your system, you must"
+ elog "add 'multipath' into your boot runlevel!"
+ fi
+}