summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/ncdu/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/ncdu/files')
-rw-r--r--sys-fs/ncdu/files/ncdu-1.11-missing-header.patch22
-rw-r--r--sys-fs/ncdu/files/ncdu-1.9-pkgconfig.patch39
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-fs/ncdu/files/ncdu-1.11-missing-header.patch b/sys-fs/ncdu/files/ncdu-1.11-missing-header.patch
new file mode 100644
index 000000000000..4c79139f7b06
--- /dev/null
+++ b/sys-fs/ncdu/files/ncdu-1.11-missing-header.patch
@@ -0,0 +1,22 @@
+From 29f347c19cb7ad17c4b401e1d984fce8eafaaafa Mon Sep 17 00:00:00 2001
+From: Yorhel <git@yorhel.nl>
+Date: Tue, 7 Apr 2015 10:39:46 +0200
+Subject: shell.c: Include sys/wait.h
+
+Required for the W* macros on OpenBSD. Reported by Brian Callahan.
+
+diff --git a/src/shell.c b/src/shell.c
+index d601b5a..eb275cd 100644
+--- a/src/shell.c
++++ b/src/shell.c
+@@ -32,6 +32,7 @@
+ #include <ncurses.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <sys/wait.h>
+
+ void shell_draw() {
+ char *full_path;
+--
+cgit v0.10.1
+
diff --git a/sys-fs/ncdu/files/ncdu-1.9-pkgconfig.patch b/sys-fs/ncdu/files/ncdu-1.9-pkgconfig.patch
new file mode 100644
index 000000000000..0d180b34239f
--- /dev/null
+++ b/sys-fs/ncdu/files/ncdu-1.9-pkgconfig.patch
@@ -0,0 +1,39 @@
+ configure.in | 21 ++++++++++++---------
+ 1 file changed, 12 insertions(+), 9 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index f4a4a2d..1333234 100644
+--- a/configure.in
++++ b/configure.in
+@@ -36,19 +36,22 @@ AC_ARG_WITH([ncursesw],
+ AC_HELP_STRING([--with-ncursesw], [compile/link with wide-char ncurses library @<:@default@:>@]),
+ [ncurses=ncursesw])
+ if test "$ncurses" = "auto" -o "$ncurses" = "ncursesw"; then
+- AC_CHECK_LIB([ncursesw],
+- [initscr],
+- [LIBS="$LIBS -lncursesw"; ncurses=ncursesw],
+- [ncurses=ncurses])
++ PKG_CHECK_MODULES([NCURSES], [ncursesw], [LIBS="$LIBS $NCURSES_LIBS"; ncurses=ncursesw],
++ [AC_CHECK_LIB([ncursesw],
++ [initscr],
++ [LIBS="$LIBS -lncursesw"; ncurses=ncursesw],
++ [ncurses=ncurses])
++ ])
+ fi
+ if test "$ncurses" = "ncurses"; then
+- AC_CHECK_LIB([ncurses],
+- [initscr],
+- [LIBS="$LIBS -lncurses"],
+- [AC_MSG_ERROR(ncurses library is required)])
++ PKG_CHECK_MODULES([NCURSES], [ncurses], [LIBS="$LIBS $NCURSES_LIBS"],
++ [AC_CHECK_LIB([ncurses],
++ [initscr],
++ [LIBS="$LIBS -lncurses"],
++ [AC_MSG_ERROR(ncurses library is required)])
++ ])
+ fi
+
+
+
+ AC_OUTPUT([Makefile])
+-