summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-11-16 23:04:24 -0700
committerTim Harder <radhermit@gentoo.org>2019-11-16 23:07:19 -0700
commit690a58eedd225549e5b6570892ae0c81d176ebbf (patch)
tree453f3063b2302243590b231e0c1f5b9ff8f7650f /sys-fs/rar2fs/rar2fs-1.28.0.ebuild
parentdev-ruby/aws-sdk: add ruby26 (diff)
downloadgentoo-690a58eedd225549e5b6570892ae0c81d176ebbf.tar.gz
gentoo-690a58eedd225549e5b6570892ae0c81d176ebbf.tar.bz2
gentoo-690a58eedd225549e5b6570892ae0c81d176ebbf.zip
sys-fs/rar2fs: version bump to 1.28.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'sys-fs/rar2fs/rar2fs-1.28.0.ebuild')
-rw-r--r--sys-fs/rar2fs/rar2fs-1.28.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-fs/rar2fs/rar2fs-1.28.0.ebuild b/sys-fs/rar2fs/rar2fs-1.28.0.ebuild
new file mode 100644
index 000000000000..d7d5e5f041b8
--- /dev/null
+++ b/sys-fs/rar2fs/rar2fs-1.28.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A FUSE based filesystem that can mount one or multiple RAR archive(s)"
+HOMEPAGE="https://hasse69.github.io/rar2fs/ https://github.com/hasse69/rar2fs"
+SRC_URI="https://github.com/hasse69/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Note that upstream unrar sometimes breaks ABI without updating the SONAME
+# version so try rebuilding rar2fs if it doesn't work following an unrar
+# upgrade.
+RDEPEND=">=app-arch/unrar-5:=
+ sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ export USER_CFLAGS="${CFLAGS}"
+
+ econf \
+ --with-unrar="${ESYSROOT}"/usr/include/libunrar \
+ --disable-static-unrar \
+ $(use_enable debug)
+}