summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/redirfs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/redirfs')
-rw-r--r--sys-fs/redirfs/Manifest2
-rw-r--r--sys-fs/redirfs/metadata.xml22
-rw-r--r--sys-fs/redirfs/redirfs-0.10.20120313.ebuild35
-rw-r--r--sys-fs/redirfs/redirfs-0.8.ebuild31
-rw-r--r--sys-fs/redirfs/redirfs-9999.ebuild41
5 files changed, 131 insertions, 0 deletions
diff --git a/sys-fs/redirfs/Manifest b/sys-fs/redirfs/Manifest
new file mode 100644
index 000000000000..e90a0fc908d2
--- /dev/null
+++ b/sys-fs/redirfs/Manifest
@@ -0,0 +1,2 @@
+DIST redirfs-0.10.20120313.tar.bz2 1479473 SHA256 2481407d004c5e205f8ce602e6db7c9e8c5090b4953e72bfb4c3a547416e0a2a SHA512 8f7973adeec40d0098ed9d7d889d345625d61d0579e5206f09ca51ce881d4e1f9193fff5d78d1a44b544924016118001dfbc653ac16f7dfbf78d32a25c60907a WHIRLPOOL 8f10add2507fe28dad7d781884ebb664be2cef639331fe23158641cf2f0276eb2703535584ef8c76b9a2d04e4ce9c22d4e4c47daea79e4699bb9aeccc8491c1a
+DIST redirfs-0.8.tar.gz 41580 SHA256 ef9248f85e3ce15cd34a9f402386ec4b5cf58f6be00cd9f195257364da913012
diff --git a/sys-fs/redirfs/metadata.xml b/sys-fs/redirfs/metadata.xml
new file mode 100644
index 000000000000..32e583418aee
--- /dev/null
+++ b/sys-fs/redirfs/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>bicatali@gentoo.org</email>
+</maintainer>
+<longdescription lang='en'>
+ The RedirFS or redirecting file system is a layer between
+ virtual file system switch (VFS) and file system drivers. It is
+ implemented as an out-of-kernel module for Linux and it provides
+ framework allowing modification of file system calls in the VFS
+ layer. The RedirFS by itself does not provide any additional
+ functionality and if it is loaded into the Linux kernel, it just
+ occupies some memory space and it does practically nothing. The
+ RedirFS is intended to be used by so-called filters. Filter is a
+ linux kernel module (LKM) that uses the RedirFS framework. Each
+ filter can add some useful functionality to the existing file
+ systems like transparent compression, transparent encryption,
+ merging contents of several directories into one, allowing writing
+ to a read-only media and others.
+</longdescription>
+</pkgmetadata>
diff --git a/sys-fs/redirfs/redirfs-0.10.20120313.ebuild b/sys-fs/redirfs/redirfs-0.10.20120313.ebuild
new file mode 100644
index 000000000000..e8e19fbd727b
--- /dev/null
+++ b/sys-fs/redirfs/redirfs-0.10.20120313.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit linux-mod
+
+KEYWORDS="~amd64 ~x86"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
+
+DESCRIPTION="Layer between virtual file system switch and file system drivers"
+HOMEPAGE="http://www.redirfs.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ SRCDIR="${S}/src/redirfs"
+ MODULE_NAMES="redirfs(misc:${SRCDIR})"
+ BUILD_PARAMS="-C ${KERNEL_DIR} M=${SRCDIR}"
+ BUILD_TARGETS="redirfs.ko"
+ linux-mod_pkg_setup
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto ${KERNEL_DIR}/include/linux
+ doins ${SRCDIR}/redirfs.h
+ dodoc ${SRCDIR}/{CHANGELOG,README,TODO}
+}
diff --git a/sys-fs/redirfs/redirfs-0.8.ebuild b/sys-fs/redirfs/redirfs-0.8.ebuild
new file mode 100644
index 000000000000..f27bdbed8dcf
--- /dev/null
+++ b/sys-fs/redirfs/redirfs-0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit linux-mod
+
+DESCRIPTION="Layer between virtual file system switch and file system drivers"
+HOMEPAGE="http://www.redirfs.org"
+SRC_URI="http://www.redirfs.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ MODULE_NAMES="redirfs(misc:)"
+ BUILD_TARGETS="redirfs.ko"
+ BUILD_PARAMS="-C ${KERNEL_DIR} M=${S} modules"
+}
+
+src_install() {
+ dodoc CHANGELOG INSTALL README TODO
+ linux-mod_src_install
+ insinto /usr/include
+ doins redirfs.h
+}
diff --git a/sys-fs/redirfs/redirfs-9999.ebuild b/sys-fs/redirfs/redirfs-9999.ebuild
new file mode 100644
index 000000000000..147bf07ac929
--- /dev/null
+++ b/sys-fs/redirfs/redirfs-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit linux-mod
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-2
+ KEYWORDS=""
+ EGIT_REPO_URI="git://www.redirfs.org/git/fhrbata/redirfs.git"
+ SRCDIR="${S}/src/redirfs"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://www.redirfs.org/packages/${P}.tar.gz"
+fi
+
+DESCRIPTION="Layer between virtual file system switch and file system drivers"
+HOMEPAGE="http://www.redirfs.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ MODULE_NAMES="redirfs(misc:${SRCDIR})"
+ BUILD_PARAMS="-C ${KERNEL_DIR} M=${SRCDIR}"
+ BUILD_TARGETS="redirfs.ko"
+ linux-mod_pkg_setup
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /usr/include
+ doins ${SRCDIR}/redirfs.h
+ dodoc ${SRCDIR}/{CHANGELOG,README,TODO}
+}