summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-03-07 21:38:26 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-03-07 21:45:04 +0000
commit1c0dbe09fe07d97672474ca4c2f52392a4c478e3 (patch)
treeca40a524efb75d38d78620fa533a990f84b62963 /sys-fs/safecopy
parentdev-libs/libpcre-debian: Create relative instead of absolute symlinks (diff)
downloadgentoo-1c0dbe09fe07d97672474ca4c2f52392a4c478e3.tar.gz
gentoo-1c0dbe09fe07d97672474ca4c2f52392a4c478e3.tar.bz2
gentoo-1c0dbe09fe07d97672474ca4c2f52392a4c478e3.zip
sys-fs/safecopy: EAPI 7
Installed files are unchanged. Package-Manager: Portage-2.3.92, Repoman-2.3.20 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'sys-fs/safecopy')
-rw-r--r--sys-fs/safecopy/safecopy-1.7.ebuild28
1 files changed, 6 insertions, 22 deletions
diff --git a/sys-fs/safecopy/safecopy-1.7.ebuild b/sys-fs/safecopy/safecopy-1.7.ebuild
index dbfe2a87a2aa..ea11400db323 100644
--- a/sys-fs/safecopy/safecopy-1.7.ebuild
+++ b/sys-fs/safecopy/safecopy-1.7.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit base
+EAPI=7
DESCRIPTION="Tool for fault-tolerant data recovery from damaged (io-errors) devices or files"
HOMEPAGE="http://safecopy.sourceforge.net"
@@ -15,34 +13,20 @@ KEYWORDS="amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND=""
-DEPEND=""
-
DOCS=( README )
-src_prepare() {
- base_src_prepare
- sed -e 's:bin/sh:bin/bash:' \
- -i "${S}"/test/test.sh || die
-}
-
src_configure() {
econf
- if use test; then
- cd "${S}"/simulator
- econf
- fi
+ cd simulator || die
+ use test && econf
}
src_compile() {
emake
- if use test; then
- cd "${S}"/simulator
- emake
- fi
+ use test && emake -C simulator
}
src_test() {
- cd "${S}"/test
+ cd test || die
./test.sh || die
}