summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-08-14 18:49:46 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-05 10:53:46 +0300
commiteca3ef766f3c0b0a547b4b582eabae79e43944e6 (patch)
tree37be2cefe2e5df3fbf808b8e128f11575361fb59 /sys-fs/simple-mtpfs
parentapp-emulation/libvirt: add apparmor rule for seavgabios (diff)
downloadgentoo-eca3ef766f3c0b0a547b4b582eabae79e43944e6.tar.gz
gentoo-eca3ef766f3c0b0a547b4b582eabae79e43944e6.tar.bz2
gentoo-eca3ef766f3c0b0a547b4b582eabae79e43944e6.zip
sys-fs/simple-mtpfs: bump to 0.4.0
Closes: https://bugs.gentoo.org/737104 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs/simple-mtpfs')
-rw-r--r--sys-fs/simple-mtpfs/Manifest1
-rw-r--r--sys-fs/simple-mtpfs/simple-mtpfs-0.4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sys-fs/simple-mtpfs/Manifest b/sys-fs/simple-mtpfs/Manifest
index f90ae56bfda0..a275e2b91998 100644
--- a/sys-fs/simple-mtpfs/Manifest
+++ b/sys-fs/simple-mtpfs/Manifest
@@ -1 +1,2 @@
DIST simple-mtpfs-0.3.0.tar.gz 36655 BLAKE2B 3e3e625268fac9454f512ce592d84fde3b3e6d190f123b82bede13bc4119ad4c0cefb4ca3e5d8a81ddf9a020dc375be389853410b0147b419a255b6c0af6047b SHA512 7d2da152708c01ddd2a39c1b56cba6470bfd320b92507530cdd8fc4f25f9500ff817eac6a5d19c775f31029ae6a0baef693987c59453c60c688b84934378f772
+DIST simple-mtpfs-0.4.0.tar.gz 36234 BLAKE2B ec5739625286b63dc6285fb83a4c71f5ed9bb8ed757eab111e543e15efbc45a5fc3a2609382f01cf18d4c6160258800963c349b6d64b2648257cde99f9359432 SHA512 6f213f9df792f33cd3842357aecf444cdc8030c89e4abc19b56a2c60f58213b5545b3d7857b0d46cdd237d0c24d5d6eb3cbe59ba9fc3c32f91396c5724ac86d7
diff --git a/sys-fs/simple-mtpfs/simple-mtpfs-0.4.0.ebuild b/sys-fs/simple-mtpfs/simple-mtpfs-0.4.0.ebuild
new file mode 100644
index 000000000000..a84aa51dbee4
--- /dev/null
+++ b/sys-fs/simple-mtpfs/simple-mtpfs-0.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Simple MTP fuse filesystem driver"
+HOMEPAGE="https://github.com/phatina/simple-mtpfs"
+SRC_URI="https://github.com/phatina/simple-mtpfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libmtp
+ sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # The tarball doesn't contain ./configure, only configure.ac and
+ # autogen.sh.
+ eautoreconf
+}