summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-10-08 17:25:50 -0700
committerMatt Turner <mattst88@gentoo.org>2019-10-08 17:38:20 -0700
commitcafa5f914f3199f836ca9ed5a9c0b2020475d972 (patch)
tree23f1f14eae3603f2aff8ac51164aa313cf2a2094 /sys-fs/squashfs-tools-ng
parentsys-fs/squashfs-tools-ng: Handle libsquashfs (diff)
downloadgentoo-cafa5f914f3199f836ca9ed5a9c0b2020475d972.tar.gz
gentoo-cafa5f914f3199f836ca9ed5a9c0b2020475d972.tar.bz2
gentoo-cafa5f914f3199f836ca9ed5a9c0b2020475d972.zip
sys-fs/squashfs-tools-ng: Version bump to 0.7
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-fs/squashfs-tools-ng')
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest1
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.7.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index d839d483f3d5..e755e953188a 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1,2 +1,3 @@
DIST squashfs-tools-ng-0.5.tar.xz 158048 BLAKE2B e8d53336a0955875eaf5a301329f620f6efd27d27d985c760a7eaaded94a60e1a7384f076311101b4a6de36b1330d7b42866079b074b6af1829d4162c1f62b38 SHA512 b39cd6e9627e71eb0fcc59a587612fe062c3f437e11342e6ec1a1fee1e6a51b38dcc881bf9a1d69578ad4686f939ece8ec02ed79a6cc6c69afe06bc6753390bf
DIST squashfs-tools-ng-0.6.1.tar.xz 203756 BLAKE2B 94d20ed11f53df4b9d6a413ad52e3d968bdbacaa0a68988672eab07664a0b3681f0de916288fdf6ce5f6d4eea4b77af08fe2da3fbbf19cc745a3a24c7ac23ba2 SHA512 f82506d298be4fbf878f68e118dbcf8377fe72ef89d8cb9a24b8cecc23c6d431b021f6b3d5312c0da155ab148a3c55aacb962e8215ac28511b203b5c5dbfb855
+DIST squashfs-tools-ng-0.7.tar.xz 372956 BLAKE2B 5fd0849c8cb0255ea56edc5b5cdc771363f5ca038f4306bb7d816ff26ce23cbd4f4652ef8ae497b8c9fe1ec09f9ebcfcf13aeb6b99b97db80a95018c25d4a3a6 SHA512 e53d7b64e68a40b49667b65d9fa8f12e977e8ca923c2fe9ce1e1def2745573f8607f7dee7ae6c06496489ef721c4c500ec40513ea5f6bd3ad4bb3a7796972b8e
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.7.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.7.ebuild
new file mode 100644
index 000000000000..22a2dbc93b62
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 lzo selinux +tools +xz zstd"
+
+DEPEND="
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:= )
+ xz? ( app-arch/xz-utils:= )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}