summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2017-11-14 03:53:01 +0100
committerAmy Liffey <amynka@gentoo.org>2017-11-15 08:54:53 +0100
commita79b297fb03eaada881c1eeef02b308f1a4e96d1 (patch)
tree7052e2fc30592e2cc7fb92ce04a0ddcb8d7efec0 /sys-fs/tmsu/tmsu-0.7.0.ebuild
parentnet-im/skype: Remove last-rited package (diff)
downloadgentoo-a79b297fb03eaada881c1eeef02b308f1a4e96d1.tar.gz
gentoo-a79b297fb03eaada881c1eeef02b308f1a4e96d1.tar.bz2
gentoo-a79b297fb03eaada881c1eeef02b308f1a4e96d1.zip
sys-fs/tmsu: version bump 0.7.0
Closes:https://bugs.gentoo.org/637180 Closes:#6186 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'sys-fs/tmsu/tmsu-0.7.0.ebuild')
-rw-r--r--sys-fs/tmsu/tmsu-0.7.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-fs/tmsu/tmsu-0.7.0.ebuild b/sys-fs/tmsu/tmsu-0.7.0.ebuild
new file mode 100644
index 000000000000..d37b33711282
--- /dev/null
+++ b/sys-fs/tmsu/tmsu-0.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_PN="github.com/oniony/TMSU/"
+DESCRIPTION="Files tagger and virtual tag-based filesystem"
+HOMEPAGE="https://github.com/oniony/TMSU/wiki"
+SRC_URI="https://github.com/oniony/TMSU/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test zsh-completion"
+
+RDEPEND="
+ zsh-completion? ( app-shells/zsh )
+"
+DEPEND="
+ dev-go/go-sqlite3
+ dev-lang/go
+ dev-libs/go-fuse
+"
+
+src_unpack() {
+ default
+ mv TMSU-${PV} ${P} || die "Failed to move sorce directory."
+}
+
+src_install() {
+ dobin misc/bin/*
+ doman misc/man/tmsu.*
+ newbin TMSU tmsu
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins misc/zsh/_tmsu
+ fi
+}