summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/udev-init-scripts/udev-init-scripts-30.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/udev-init-scripts/udev-init-scripts-30.ebuild')
-rw-r--r--sys-fs/udev-init-scripts/udev-init-scripts-30.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-fs/udev-init-scripts/udev-init-scripts-30.ebuild b/sys-fs/udev-init-scripts/udev-init-scripts-30.ebuild
new file mode 100644
index 000000000000..8cdd11a12c3d
--- /dev/null
+++ b/sys-fs/udev-init-scripts/udev-init-scripts-30.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/udev-gentoo-scripts.git"
+ inherit git-r3
+else
+ SRC_URI="http://dev.gentoo.org/~williamh/dist/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+inherit eutils
+
+DESCRIPTION="udev startup scripts for openrc"
+HOMEPAGE="http://www.gentoo.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND=">=virtual/udev-217
+ !<sys-apps/openrc-0.14"
+
+src_prepare() {
+ epatch_user
+}
+
+pkg_postinst() {
+ # Add udev and udev-trigger to the sysinit runlevel automatically.
+ for f in udev udev-trigger; do
+ if [[ -x ${ROOT%/}/etc/init.d/${f} &&
+ -d ${ROOT%/}/etc/runlevels/sysinit &&
+ ! -L "${ROOT%/}/etc/runlevels/sysinit/${f}" ]]; then
+ ln -snf /etc/init.d/${f} "${ROOT%/}"/etc/runlevels/sysinit/${f}
+ ewarn "Adding ${f} to the sysinit runlevel"
+ fi
+ done
+
+ if ! has_version "sys-fs/eudev[rule-generator]" && \
+ [[ -x $(type -P rc-update) ]] && rc-update show | grep udev-postmount | grep -qs 'boot\|default\|sysinit'; then
+ ewarn "The udev-postmount service has been removed because the reasons for"
+ ewarn "its existance have been removed upstream."
+ ewarn "Please remove it from your runlevels."
+ fi
+}