summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-08-25 20:45:58 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-08-25 21:05:46 +0200
commit39919014754bfa45be491927edf060f9b5fd0ea3 (patch)
tree001097e1d1dda9f60c22b8018a551ec4a1c073a1 /sys-fs/xfsprogs
parentnet-libs/nghttp2: Removed old. (diff)
downloadgentoo-39919014754bfa45be491927edf060f9b5fd0ea3.tar.gz
gentoo-39919014754bfa45be491927edf060f9b5fd0ea3.tar.bz2
gentoo-39919014754bfa45be491927edf060f9b5fd0ea3.zip
sys-fs/xfsprogs: Bump to version 4.18.0
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-fs/xfsprogs')
-rw-r--r--sys-fs/xfsprogs/Manifest1
-rw-r--r--sys-fs/xfsprogs/xfsprogs-4.18.0.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/sys-fs/xfsprogs/Manifest b/sys-fs/xfsprogs/Manifest
index 2204bd7af60b..1a243b977867 100644
--- a/sys-fs/xfsprogs/Manifest
+++ b/sys-fs/xfsprogs/Manifest
@@ -2,3 +2,4 @@ DIST xfsprogs-4.14.0.tar.xz 1137048 BLAKE2B b58373ca7f58e5d887cf18ed2aab169aed4b
DIST xfsprogs-4.15.1.tar.xz 1188964 BLAKE2B 7b4d1d2f71a0678f9246045e576262d6f3b3c59322e0b33b37dc46d84cdf5407a4b2fd6f2b99dd7647e9bfe9fe312fefe8162013dec9162f3a071421323aa52d SHA512 4ec3f0438f33322f0ff6e5acb27cbb554ab48df3ae0ef11071992b085016f84b49ca7bdbaf3a6859427877ea9c419bcd37ac3058914d67409ba2d65e586508ee
DIST xfsprogs-4.16.1.tar.xz 1199632 BLAKE2B 26448ce8ec691d117c0b41aebcb692994ad5a65418ac5af9631eab75191201a265ec9bce92d4076049a4182a879741329f20e5f54343afeef826cf1dfbfcf0d1 SHA512 d3cf3b07e07864341c351a078736ff7c721d86c177e65f131dc6e023cade74a5e07fecbc435d69946d76d587b138e66cddcd763954e15ed0dd17c056a83e2a19
DIST xfsprogs-4.17.0.tar.xz 1205508 BLAKE2B 46168792c1e4c335b7ed9e7489afc20d7df4b4e554eb86043b2c19303879491cc4746b18d23fdff3e2f92ca3887ac27957ae57e85ba784476d8891ea6909d67e SHA512 996de920c76de596b6175e4ae4ba9de208c16fbcf9362bbb44d25ee1c12b249d0178fc5cc93dc5a434ab20e6d515d64a3f51b8e89905b5b033b28a3638f4d400
+DIST xfsprogs-4.18.0.tar.xz 1214480 BLAKE2B 78db41319e53be1f03b66f85ecc7c50e0c6658fa3fd8ddd8539bac04e656614a5cb54dc930a324d9df6afe4024c2be10259b903e1ca0ccd0ffb340e7410692c2 SHA512 0629400f8824620138928a7d72908b7a852408814238a55e11d6eb3b2da42cd56273960430d3ea729a9bce95f605d225607940d4728b68c468c39eb5a9a590be
diff --git a/sys-fs/xfsprogs/xfsprogs-4.18.0.ebuild b/sys-fs/xfsprogs/xfsprogs-4.18.0.ebuild
new file mode 100644
index 000000000000..273db91aea0b
--- /dev/null
+++ b/sys-fs/xfsprogs/xfsprogs-4.18.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs multilib systemd
+
+DESCRIPTION="xfs filesystem utilities"
+HOMEPAGE="https://xfs.wiki.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="icu libedit nls readline static static-libs"
+REQUIRED_USE="static? ( static-libs )"
+
+LIB_DEPEND=">=sys-apps/util-linux-2.17.2[static-libs(+)]
+ icu? ( dev-libs/icu:=[static-libs(+)] )
+ readline? ( sys-libs/readline:0=[static-libs(+)] )
+ !readline? ( libedit? ( dev-libs/libedit[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ !<sys-fs/xfsdump-3"
+DEPEND="${RDEPEND}
+ static? (
+ ${LIB_DEPEND}
+ readline? ( sys-libs/ncurses:0=[static-libs] )
+ )
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.9.0-underlinking.patch
+ "${FILESDIR}"/${PN}-4.15.0-sharedlibs.patch
+ "${FILESDIR}"/${PN}-4.15.0-docdir.patch
+)
+
+pkg_setup() {
+ if use readline && use libedit ; then
+ ewarn "You have USE='readline libedit' but these are exclusive."
+ ewarn "Defaulting to readline; please disable this USE flag if you want libedit."
+ fi
+}
+
+src_prepare() {
+ default
+
+ # LLDFLAGS is used for programs, so apply -all-static when USE=static is enabled.
+ # Clear out -static from all flags since we want to link against dynamic xfs libs.
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e "1iLLDFLAGS += $(usex static '-all-static' '')" \
+ include/builddefs.in || die
+ find -name Makefile -exec \
+ sed -i -r -e '/^LLDFLAGS [+]?= -static(-libtool-libs)?$/d' {} +
+
+ # TODO: Write a patch for configure.ac to use pkg-config for the uuid-part.
+ if use static && use readline ; then
+ sed -i \
+ -e 's|-lreadline|& -lncurses|' \
+ -e 's|-lblkid|& -luuid|' \
+ configure || die
+ fi
+}
+
+src_configure() {
+ export DEBUG=-DNDEBUG
+ export OPTIMIZER=${CFLAGS}
+ unset PLATFORM # if set in user env, this breaks configure
+
+ local myconf=(
+ --disable-lto #655638
+ --enable-blkid
+ --with-crond-dir="${EPREFIX}/etc/cron.d"
+ --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ $(use_enable icu libicu)
+ $(use_enable nls gettext)
+ $(use_enable readline)
+ $(usex readline --disable-editline $(use_enable libedit editline))
+ )
+ if use static || use static-libs ; then
+ myconf+=( --enable-static )
+ else
+ myconf+=( --disable-static )
+ fi
+
+ econf "${myconf[@]}"
+
+ MAKEOPTS+=" V=1"
+}
+
+src_install() {
+ emake DIST_ROOT="${ED}" install
+ # parallel install fails on this target for >=xfsprogs-3.2.0
+ emake -j1 DIST_ROOT="${ED}" install-dev
+
+ # handle is for xfsdump, the rest for xfsprogs
+ gen_usr_ldscript -a handle xcmd xfs xlog frog
+ # removing unnecessary .la files if not needed
+ use static-libs || find "${ED}" -name '*.la' -delete
+}