summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/zerofree
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/zerofree')
-rw-r--r--sys-fs/zerofree/Manifest2
-rw-r--r--sys-fs/zerofree/metadata.xml12
-rw-r--r--sys-fs/zerofree/zerofree-1.0.1.ebuild38
-rw-r--r--sys-fs/zerofree/zerofree-1.0.3.ebuild38
4 files changed, 90 insertions, 0 deletions
diff --git a/sys-fs/zerofree/Manifest b/sys-fs/zerofree/Manifest
new file mode 100644
index 000000000000..87c94883bc47
--- /dev/null
+++ b/sys-fs/zerofree/Manifest
@@ -0,0 +1,2 @@
+DIST zerofree-1.0.1.tgz 8333 SHA256 ddf33ac01e554997659841b723bd826dfcd2554f31176b7a05993236cefd3cd8
+DIST zerofree-1.0.3.tgz 8506 SHA256 3acfda860be0f0ddcb5c982ff3b4475b1ee8cc35a90ae2a910e93261dbe0ccf6 SHA512 e23d343471240382629b4c86b6caa74571a77fb19f1b31bbbd9fad03ba1b42898f8ae042d1238d9c91d9b7fbc9893fb708cb557d3bbd9ab9a024aca6a8ddbbe3 WHIRLPOOL b1954c9a60bcbd8ba7acaf8c50e2ba3f9748346825d2b97f0666a568597400ff9de2eae42aa2c47cbec1efd9dabe1975b8ce34c82ecb847bfdf08b4c50510499
diff --git a/sys-fs/zerofree/metadata.xml b/sys-fs/zerofree/metadata.xml
new file mode 100644
index 000000000000..984946d9eb56
--- /dev/null
+++ b/sys-fs/zerofree/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>kumba@gentoo.org</email>
+ </maintainer>
+
+ <longdescription>
+ zerofree is a small utility designed to zero-out the free space on a filesystem. It is especially useful for guests on a virtual machine before compacting their disk images.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/sys-fs/zerofree/zerofree-1.0.1.ebuild b/sys-fs/zerofree/zerofree-1.0.1.ebuild
new file mode 100644
index 000000000000..c8ff374e4e76
--- /dev/null
+++ b/sys-fs/zerofree/zerofree-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Zero's out all free space on a filesystem"
+HOMEPAGE="http://intgat.tigress.co.uk/rmy/uml/index.html"
+SRC_URI="http://intgat.tigress.co.uk/rmy/uml/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~mips"
+IUSE=""
+
+DEPEND="sys-libs/e2fsprogs-libs"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Honor system CFLAGS.
+ sed -i \
+ -e "s:CC=gcc:CC=$(tc-getCC)\nCFLAGS=${CFLAGS}\nLDFLAGS=${LDFLAGS}:g" \
+ -e "s:-o zerofree:\$(CFLAGS) \$(LDFLAGS) -o zerofree:g" \
+ -e "/-lext2fs/{ s:-lext2fs::g; s:$: -lext2fs:g; }" \
+ Makefile || die "Failed to sed the Makefile"
+}
+
+src_compile() {
+ # Just a Makefile, nothing fancy.
+ make || die "Failed to compile ${PN}."
+}
+
+src_install() {
+ # Install into /sbin
+ into /
+ dosbin zerofree
+}
diff --git a/sys-fs/zerofree/zerofree-1.0.3.ebuild b/sys-fs/zerofree/zerofree-1.0.3.ebuild
new file mode 100644
index 000000000000..c8ff374e4e76
--- /dev/null
+++ b/sys-fs/zerofree/zerofree-1.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Zero's out all free space on a filesystem"
+HOMEPAGE="http://intgat.tigress.co.uk/rmy/uml/index.html"
+SRC_URI="http://intgat.tigress.co.uk/rmy/uml/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~mips"
+IUSE=""
+
+DEPEND="sys-libs/e2fsprogs-libs"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Honor system CFLAGS.
+ sed -i \
+ -e "s:CC=gcc:CC=$(tc-getCC)\nCFLAGS=${CFLAGS}\nLDFLAGS=${LDFLAGS}:g" \
+ -e "s:-o zerofree:\$(CFLAGS) \$(LDFLAGS) -o zerofree:g" \
+ -e "/-lext2fs/{ s:-lext2fs::g; s:$: -lext2fs:g; }" \
+ Makefile || die "Failed to sed the Makefile"
+}
+
+src_compile() {
+ # Just a Makefile, nothing fancy.
+ make || die "Failed to compile ${PN}."
+}
+
+src_install() {
+ # Install into /sbin
+ into /
+ dosbin zerofree
+}