summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorHank Leininger <hlein@korelogic.com>2020-06-08 01:34:52 -0600
committerJoonas Niilola <juippis@gentoo.org>2020-06-08 16:41:25 +0300
commit0d2f6537777791fd40c117d1e491d7433b7a5cd0 (patch)
tree88b79cb7c457f4f7a667d7ad2b25dce6757693a5 /sys-fs
parentsys-fs/loop-aes: Added myself as proxy maintainer. (diff)
downloadgentoo-0d2f6537777791fd40c117d1e491d7433b7a5cd0.tar.gz
gentoo-0d2f6537777791fd40c117d1e491d7433b7a5cd0.tar.bz2
gentoo-0d2f6537777791fd40c117d1e491d7433b7a5cd0.zip
sys-fs/loop-aes: Version bump to 3.7q
The new version of sys-fs/loop-aes fixes compilation on recent 5.2+ kernels (tested with gentoo-sources-5.4.8 on x86_64). Signed-off-by: Hank Leininger <hlein@korelogic.com> Closes: https://bugs.gentoo.org/689888 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Closes: https://github.com/gentoo/gentoo/pull/14292 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/loop-aes/Manifest1
-rw-r--r--sys-fs/loop-aes/loop-aes-3.7q.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-fs/loop-aes/Manifest b/sys-fs/loop-aes/Manifest
index 5e37fa21dfb5..8799f267df66 100644
--- a/sys-fs/loop-aes/Manifest
+++ b/sys-fs/loop-aes/Manifest
@@ -1 +1,2 @@
DIST loop-AES-v3.7n.tar.bz2 373901 BLAKE2B 5cac9bd55f35a6cf0c056a6a2e75a48f49c1d23b7ebe1821e10dab522508e64ed23e5993dbcc19dbdeaab6c315ee4e71c8ecc17d9da41a5ad0794abc92563d7e SHA512 d190561f92a47292285e44c728bf1fcf9b7dd9c54f970ebc11a2988686f409515687a22028187756baaa4622903564e2646971a63eba13557c6ce78dc1f0bb96
+DIST loop-AES-v3.7q.tar.bz2 376027 BLAKE2B 7f3206196fcb7ecc928bda4cd127042f61cd5ac7f39e483fb91db388572be1c8e252d5c4adb653e6fd00ff6a7ba4c1406c35f2b2659e9cb38fd817f1bdb2a15f SHA512 103869695f6b18bcc765804865468db4b24fc2fcce3ec97d8468fdc0bd37c480386960730e280cd93c707026dddc5e79d8d25e2601c3678330e016835166ad20
diff --git a/sys-fs/loop-aes/loop-aes-3.7q.ebuild b/sys-fs/loop-aes/loop-aes-3.7q.ebuild
new file mode 100644
index 000000000000..6879462d4158
--- /dev/null
+++ b/sys-fs/loop-aes/loop-aes-3.7q.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+MY_P="${PN/aes/AES}-v${PV}"
+
+DESCRIPTION="Linux kernel module to encrypt disk partitions with AES cipher"
+HOMEPAGE="http://loop-aes.sourceforge.net/loop-AES.README"
+SRC_URI="http://loop-aes.sourceforge.net/loop-AES/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="cpu_flags_x86_aes extra-ciphers keyscrub cpu_flags_x86_padlock"
+
+DEPEND="app-crypt/loop-aes-losetup"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ CONFIG_CHECK="!BLK_DEV_LOOP"
+ MODULE_NAMES="loop(block::tmp-d-kbuild)"
+ BUILD_TARGETS="all"
+
+ BUILD_PARAMS=" \
+ V=1 \
+ LINUX_SOURCE=\"${KERNEL_DIR}\" \
+ KBUILD_OUTPUT=\"${KBUILD_OUTPUT}\" \
+ USE_KBUILD=y MODINST=n RUNDM=n"
+ use cpu_flags_x86_aes && BUILD_PARAMS+=" INTELAES=y"
+ use keyscrub && BUILD_PARAMS+=" KEYSCRUB=y"
+ use cpu_flags_x86_padlock && BUILD_PARAMS+=" PADLOCK=y"
+
+ if use extra-ciphers; then
+ MODULE_NAMES="${MODULE_NAMES}
+ loop_blowfish(block::tmp-d-kbuild)
+ loop_serpent(block::tmp-d-kbuild)
+ loop_twofish(block::tmp-d-kbuild)"
+ BUILD_PARAMS+=" EXTRA_CIPHERS=y"
+ fi
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README
+ dobin loop-aes-keygen
+ doman loop-aes-keygen.1
+
+ into /
+ dosbin build-initrd.sh
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo
+ einfo "For more instructions take a look at examples in README at:"
+ einfo "'${EPREFIX}/usr/share/doc/${PF}'"
+ einfo
+ einfo "If you have a newer Intel processor (i5, i7), and you use AES"
+ einfo "you may want to consider using the aes-ni use flag. It will"
+ einfo "use your processors native AES instructions giving quite a speed"
+ einfo "increase."
+ einfo
+}