summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-21 04:47:47 +0000
committerSam James <sam@gentoo.org>2022-12-21 04:47:47 +0000
commit0d3cc2503dad31eb09c3e9a232d83eab4383dcca (patch)
treeee5701ec09e8933334043ce3b1eab10631425231 /sys-fs
parentsci-mathematics/singular: drop 4.2.1_p3-r1 (diff)
downloadgentoo-0d3cc2503dad31eb09c3e9a232d83eab4383dcca.tar.gz
gentoo-0d3cc2503dad31eb09c3e9a232d83eab4383dcca.tar.bz2
gentoo-0d3cc2503dad31eb09c3e9a232d83eab4383dcca.zip
sys-fs/xfsdump: add 3.1.12
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsdump/Manifest1
-rw-r--r--sys-fs/xfsdump/xfsdump-3.1.12.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/sys-fs/xfsdump/Manifest b/sys-fs/xfsdump/Manifest
index e39d69bff18e..dc9e339803b5 100644
--- a/sys-fs/xfsdump/Manifest
+++ b/sys-fs/xfsdump/Manifest
@@ -1,2 +1,3 @@
DIST xfsdump-3.1.10.tar.xz 609424 BLAKE2B 742d392c4ca4532e64ab8fd89a27b0d7c669e3f977fb9362f3f41e1db09c250951aff3906a5f598892cf58b00a7aab636864af9461afb724feec2708f52cdbd9 SHA512 8a1b671b22fffb5d2eac45d5fd7a2948c137b3ca21fde06779cff13fc6eaa27286876f56715f2eeb82ce107278d763028474260a54a8fec722e5a5d7c5875c9a
DIST xfsdump-3.1.11.tar.xz 609484 BLAKE2B 22efba866ce2eb1684b97b15184b967dc75546595f4450955a93ba500d4982bb4d0385bf5a2d4f66c985974d96c8d7b668b5f6684258f555fedd92139ff692ec SHA512 9065e373f447e0ba5654b67d0db5a022515769b09db5398c5ee68d80bf6619ff459da0986cf9af5f17277608c26c407cba260cafa4f4ece6b5ece5fab1c455c7
+DIST xfsdump-3.1.12.tar.xz 609500 BLAKE2B 2cd39e9f66459d75e9a254c3409279fecb95883468fc933d4d8326d00e89422ce433472c98073aa2aef8c6c4a3a1ed7e5ef94584993eb4087b2a4667187c6aee SHA512 803a3b639aef35ec882f40faeaabf381973ba2636ce0c9d06568361f5398c3c6842ffe184fc01441bf51bb1ed1b9e40b012715c09c8cc942484cc031a8eb1757
diff --git a/sys-fs/xfsdump/xfsdump-3.1.12.ebuild b/sys-fs/xfsdump/xfsdump-3.1.12.ebuild
new file mode 100644
index 000000000000..c12ca856d9c4
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-3.1.12.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="XFS dump/restore utilities"
+HOMEPAGE="https://xfs.wiki.kernel.org/ https://git.kernel.org/pub/scm/fs/xfs/xfsdump-dev.git/"
+SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE="ncurses nls"
+
+RDEPEND="
+ >=sys-apps/attr-2.4.19
+ sys-apps/util-linux
+ sys-fs/e2fsprogs
+ >=sys-fs/xfsprogs-3.2.0
+ ncurses? ( sys-libs/ncurses:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ncurses? ( virtual/pkgconfig )
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+ # bug #335115
+ "${FILESDIR}"/${PN}-3.1.9-prompt-overflow.patch
+ # bug #311881
+ "${FILESDIR}"/${PN}-3.1.9-no-symlink.patch
+ # bug #561664
+ "${FILESDIR}"/${PN}-3.1.6-linguas.patch
+
+ "${FILESDIR}"/${PN}-3.1.9-fix-docs.patch
+ "${FILESDIR}"/${PN}-3.1.9-skip-inventory-debian-subfolder.patch
+)
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die
+
+ # bug #605852
+ sed -i \
+ -e "s:enable_curses=[a-z]*:enable_curses=$(usex ncurses):" \
+ -e "s:libcurses=\"[^\"]*\":libcurses='$(use ncurses && $(tc-getPKG_CONFIG) --libs ncurses)':" \
+ configure || die
+
+ default
+}
+
+src_configure() {
+ # bug #184564
+ unset PLATFORM
+
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+
+ local myeconfargs=(
+ $(use_enable nls gettext)
+ --libdir="${EPREFIX}/$(get_libdir)"
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)"
+ --sbindir="${EPREFIX}/sbin"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # Enable verbose build
+ emake V=1
+}