summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2016-04-02 11:03:46 -0500
committerErik Mackdanz <stasibear@gentoo.org>2016-04-02 11:03:46 -0500
commit1b09d9fca908fb94df2279400169be39b66a1e22 (patch)
tree09e1a221859fdb21268fb50c197288178654beee /sys-fs
parentapp-admin/collectd: do not RDEPEND on libtool but rather on libltdl. (diff)
downloadgentoo-1b09d9fca908fb94df2279400169be39b66a1e22.tar.gz
gentoo-1b09d9fca908fb94df2279400169be39b66a1e22.tar.bz2
gentoo-1b09d9fca908fb94df2279400169be39b66a1e22.zip
sys-fs/lxcfs: bump to 2.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lxcfs/Manifest1
-rw-r--r--sys-fs/lxcfs/files/lxcfs-2.0.0.initd27
-rw-r--r--sys-fs/lxcfs/lxcfs-2.0.0.ebuild59
3 files changed, 87 insertions, 0 deletions
diff --git a/sys-fs/lxcfs/Manifest b/sys-fs/lxcfs/Manifest
index 8debc47da4a2..556cdefe3bdb 100644
--- a/sys-fs/lxcfs/Manifest
+++ b/sys-fs/lxcfs/Manifest
@@ -1,3 +1,4 @@
DIST lxcfs-0.16.tar.gz 35307 SHA256 a43c303ec46f4f25b14b7973726b2dc04231a126763b9fe6e0b080d608c04086 SHA512 536b7b6109b2b9d508c37baa1e4824d0cac37eadc2c046f49db89e24adb5474d6a67410e3c0cbb970c73d2dfe7e3757a4ce08577018c2fdb787668ed31af3a03 WHIRLPOOL 718505531388f517b154aff3cca18d5526a9d18163e22e95a5cd496757f3261b2342d52f0de704d9fe7d41d5623099f3c41493cd17668fc74facf2987b27eea5
DIST lxcfs-0.17.tar.gz 40501 SHA256 bcfe14a1ab4b717af1750b04c891a70b59f167d166c2db74984610041c926745 SHA512 dbc38265a65056330e46b8cc56558c6d14e13102c5e6c65a446749f5370c25d70a3a008d22c64b7d435c60e31bbe3efba887fd4f98c0a62fb5ad60c15366b174 WHIRLPOOL af4c0b03ede15414b53670a1363fa240986252b0ad1de8b0e13f99150ef4b2d419f63b6f96e94015344665c118c8599e1e97fb94854be89fc884ba40b96ec2c0
+DIST lxcfs-2.0.0.tar.gz 48655 SHA256 4c03114a85aff530bf385b724b992470ffb97c6bf759d61900cb93f4d12c517d SHA512 44b35b6c275366f88e036ed1e136cb193b65024fcbdff250658d360fced14bec84a2bcfa9f8ca28af9205f38babdd5520cfa42a5521cf545c42df80eec40c1b8 WHIRLPOOL 8972fe4838a3ec157479a9bed9404ba51d7ea47efe7e37c2b9f872fcab6068daef6898ef143304868003748a50068cc5634041020d6b6ced0acca97ffd9d8d07
DIST lxcfs-2.0.0_beta2.tar.gz 44421 SHA256 4eacbbb51031ebd0776f050d7279b2076f7b4e156503f1bbe88e034f181e1d38 SHA512 d62bccc687873c060f299a726debc4642a0900f7e7a460b5c37dcb0b5d7cb75cd5b98ee03f129ccddbe62085510e1760db73010674333536f7126d01987262f4 WHIRLPOOL 470c6118a5560ff5fd447a409d136453b423d0b27a2f00652316b9415f68e08d349fc0e75edb1d312f7a25709bf96621574bd200c8fc92808a9e4eb59aada971
diff --git a/sys-fs/lxcfs/files/lxcfs-2.0.0.initd b/sys-fs/lxcfs/files/lxcfs-2.0.0.initd
new file mode 100644
index 000000000000..a85021401a7d
--- /dev/null
+++ b/sys-fs/lxcfs/files/lxcfs-2.0.0.initd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DAEMON=/usr/bin/lxcfs
+PIDFILE=/run/lxcfs.pid
+
+start() {
+ ebegin "Starting lxcfs"
+
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${DAEMON} \
+ --background \
+ --make-pidfile \
+ -- \
+ -f -o allow_other /var/lib/lxcfs
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping lxcfs"
+ start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
+ eend $?
+}
diff --git a/sys-fs/lxcfs/lxcfs-2.0.0.ebuild b/sys-fs/lxcfs/lxcfs-2.0.0.ebuild
new file mode 100644
index 000000000000..7cc6d80d7c42
--- /dev/null
+++ b/sys-fs/lxcfs/lxcfs-2.0.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils systemd vcs-snapshot versionator
+DESCRIPTION="FUSE filesystem for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/lxc/lxcfs.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ # e.g. upstream is 2.0.0.beta2, we want 2.0.0_beta2
+ UPSTREAM_PV=$(replace_version_separator 3 '.' )
+ SRC_URI="https://github.com/lxc/lxcfs/archive/${PN}-${UPSTREAM_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+#IUSE="test"
+
+# Omit all dbus. Upstream appears to require it because systemd, but
+# lxcfs makes no direct use of dbus.
+RDEPEND="
+ dev-libs/glib:2
+ sys-fs/fuse
+ virtual/pam
+"
+DEPEND="
+ sys-apps/help2man
+ ${RDEPEND}
+"
+
+src_prepare() {
+ ./bootstrap.sh || die "Failed to bootstrap configure files"
+}
+
+src_configure() {
+ econf --localstatedir=/var
+}
+
+# Test suite fails for me
+# src_test() {
+# emake tests
+# tests/main.sh || die "Tests failed"
+# }
+
+src_install() {
+ default
+ dodir /var/lib/lxcfs
+ newinitd "${FILESDIR}"/${P}.initd lxcfs
+ systemd_dounit config/init/systemd/lxcfs.service
+}