summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-10 16:48:19 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-10 16:49:03 -0700
commit244438471848f4a488e951cc0403d20a1927b29f (patch)
treec69d6feeecc2eae4988d3adfc85c940330f5fb5b /sys-fs
parentwww-plugins/chrome-binary-plugins: automated update (84.0.4147.45) (diff)
downloadgentoo-244438471848f4a488e951cc0403d20a1927b29f.tar.gz
gentoo-244438471848f4a488e951cc0403d20a1927b29f.tar.bz2
gentoo-244438471848f4a488e951cc0403d20a1927b29f.zip
sys-fs/zfs: clean up files dir
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs/files/0.7.13-ZPOOL_IMPORT_UDEV_TIMEOUT_MS.patch70
-rw-r--r--sys-fs/zfs/files/0.8.3-fno-common.patch83
-rw-r--r--sys-fs/zfs/files/0.8.3-zfs-functions.patch51
-rw-r--r--sys-fs/zfs/files/zfs-init.sh.in29
-rw-r--r--sys-fs/zfs/files/zfs.service.in16
5 files changed, 0 insertions, 249 deletions
diff --git a/sys-fs/zfs/files/0.7.13-ZPOOL_IMPORT_UDEV_TIMEOUT_MS.patch b/sys-fs/zfs/files/0.7.13-ZPOOL_IMPORT_UDEV_TIMEOUT_MS.patch
deleted file mode 100644
index 922e5951bdf0..000000000000
--- a/sys-fs/zfs/files/0.7.13-ZPOOL_IMPORT_UDEV_TIMEOUT_MS.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From a0767672aac01f41516550e3808ff72da893102f Mon Sep 17 00:00:00 2001
-From: Georgy Yakovlev <gyakovlev@gentoo.org>
-Date: Tue, 26 Nov 2019 12:07:36 -0800
-Subject: [PATCH] backport udev timeout patch
-
-https://github.com/zfsonlinux/zfs/commit/803884217f9b9b5fb235d7c5e78a809d271f6387
----
- lib/libzfs/libzfs_import.c | 11 ++++++++++-
- man/man8/zpool.8 | 6 ++++++
- 2 files changed, 16 insertions(+), 1 deletion(-)
-
-diff --git a/lib/libzfs/libzfs_import.c b/lib/libzfs/libzfs_import.c
-index 9dbf207..cd08806 100644
---- a/lib/libzfs/libzfs_import.c
-+++ b/lib/libzfs/libzfs_import.c
-@@ -53,6 +53,7 @@
- #endif
- #include <stddef.h>
- #include <stdlib.h>
-+#include <stdio.h>
- #include <string.h>
- #include <sys/stat.h>
- #include <unistd.h>
-@@ -1594,17 +1595,25 @@ zpool_open_func(void *arg)
- if (rn->rn_labelpaths) {
- char *path = NULL;
- char *devid = NULL;
-+ char *env = NULL;
- rdsk_node_t *slice;
- avl_index_t where;
-+ int timeout;
- int error;
-
- if (label_paths(rn->rn_hdl, rn->rn_config, &path, &devid))
- return;
-
-+ env = getenv("ZPOOL_IMPORT_UDEV_TIMEOUT_MS");
-+ if ((env == NULL) || sscanf(env, "%d", &timeout) != 1 ||
-+ timeout < 0) {
-+ timeout = DISK_LABEL_WAIT;
-+ }
-+
- /*
- * Allow devlinks to stabilize so all paths are available.
- */
-- zpool_label_disk_wait(rn->rn_name, DISK_LABEL_WAIT);
-+ zpool_label_disk_wait(rn->rn_name, timeout);
-
- if (path != NULL) {
- slice = zfs_alloc(hdl, sizeof (rdsk_node_t));
-diff --git a/man/man8/zpool.8 b/man/man8/zpool.8
-index 46e531e..10a19b5 100644
---- a/man/man8/zpool.8
-+++ b/man/man8/zpool.8
-@@ -2291,6 +2291,12 @@ Similar to the
- option in
- .Nm zpool import .
- .El
-+.Bl -tag -width "ZPOOL_IMPORT_UDEV_TIMEOUT_MS"
-+.It Ev ZPOOL_IMPORT_UDEV_TIMEOUT_MS
-+The maximum time in milliseconds that
-+.Nm zpool import
-+will wait for an expected device to be available.
-+.El
- .Bl -tag -width "ZPOOL_VDEV_NAME_GUID"
- .It Ev ZPOOL_VDEV_NAME_GUID
- Cause
---
-2.24.0
-
diff --git a/sys-fs/zfs/files/0.8.3-fno-common.patch b/sys-fs/zfs/files/0.8.3-fno-common.patch
deleted file mode 100644
index 3b09d8bbc597..000000000000
--- a/sys-fs/zfs/files/0.8.3-fno-common.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From af09c050e95bebbaeca52156218f3f91e8c9951a Mon Sep 17 00:00:00 2001
-From: Romain Dolbeau <romain.dolbeau@european-processor-initiative.eu>
-Date: Thu, 6 Feb 2020 18:25:29 +0100
-Subject: [PATCH] Fix static data to link with -fno-common
-
--fno-common is the new default in GCC 10, replacing -fcommon in
-GCC <= 9, so static data must only be allocated once.
-
-Reviewed-by: Brian Behlendorf <behlendorf1@llnl.gov>
-Signed-off-by: Romain Dolbeau <romain.dolbeau@european-processor-initiative.eu>
-Closes #9943
----
- cmd/zfs/zfs_util.h | 2 +-
- cmd/zpool/zpool_main.c | 2 ++
- cmd/zpool/zpool_util.h | 2 +-
- lib/libshare/smb.c | 2 ++
- lib/libshare/smb.h | 2 +-
- 5 files changed, 7 insertions(+), 3 deletions(-)
-
-diff --git a/cmd/zfs/zfs_util.h b/cmd/zfs/zfs_util.h
-index 3ddff9e22d7..a56af59adb1 100644
---- a/cmd/zfs/zfs_util.h
-+++ b/cmd/zfs/zfs_util.h
-@@ -33,7 +33,7 @@ extern "C" {
-
- void * safe_malloc(size_t size);
- void nomem(void);
--libzfs_handle_t *g_zfs;
-+extern libzfs_handle_t *g_zfs;
-
- #ifdef __cplusplus
- }
-diff --git a/cmd/zpool/zpool_main.c b/cmd/zpool/zpool_main.c
-index ae5e8a370fc..ff4f44d4652 100644
---- a/cmd/zpool/zpool_main.c
-+++ b/cmd/zpool/zpool_main.c
-@@ -76,6 +76,8 @@
-
- #include "statcommon.h"
-
-+libzfs_handle_t *g_zfs;
-+
- static int zpool_do_create(int, char **);
- static int zpool_do_destroy(int, char **);
-
-diff --git a/cmd/zpool/zpool_util.h b/cmd/zpool/zpool_util.h
-index ce760df723c..1f23f61aaa4 100644
---- a/cmd/zpool/zpool_util.h
-+++ b/cmd/zpool/zpool_util.h
-@@ -79,7 +79,7 @@ void pool_list_free(zpool_list_t *);
- int pool_list_count(zpool_list_t *);
- void pool_list_remove(zpool_list_t *, zpool_handle_t *);
-
--libzfs_handle_t *g_zfs;
-+extern libzfs_handle_t *g_zfs;
-
-
- typedef struct vdev_cmd_data
-diff --git a/lib/libshare/smb.c b/lib/libshare/smb.c
-index a95607ee032..f567f7c49d7 100644
---- a/lib/libshare/smb.c
-+++ b/lib/libshare/smb.c
-@@ -65,6 +65,8 @@ static boolean_t smb_available(void);
-
- static sa_fstype_t *smb_fstype;
-
-+smb_share_t *smb_shares;
-+
- /*
- * Retrieve the list of SMB shares.
- */
-diff --git a/lib/libshare/smb.h b/lib/libshare/smb.h
-index 7a0c0fd162d..8ea44677f9a 100644
---- a/lib/libshare/smb.h
-+++ b/lib/libshare/smb.h
-@@ -44,6 +44,6 @@ typedef struct smb_share_s {
- struct smb_share_s *next;
- } smb_share_t;
-
--smb_share_t *smb_shares;
-+extern smb_share_t *smb_shares;
-
- void libshare_smb_init(void);
diff --git a/sys-fs/zfs/files/0.8.3-zfs-functions.patch b/sys-fs/zfs/files/0.8.3-zfs-functions.patch
deleted file mode 100644
index 9cce3e1c1a7d..000000000000
--- a/sys-fs/zfs/files/0.8.3-zfs-functions.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 00478e1b5141f8b6ceaf14c173382d1aa11878b9 Mon Sep 17 00:00:00 2001
-From: Tony Hutter <hutter2@llnl.gov>
-Date: Thu, 6 Feb 2020 09:28:20 -0800
-Subject: [PATCH] Fix zfs-functions packaging bug
-
-This fixes a bug where the generated zfs-functions was being included along
-with original zfs-functions.in in the make dist tarball. This caused an
-unfortunate series of events during build/packaging that resulted in the
-RPM-installed /etc/zfs/zfs-functions listing the paths as:
-
-ZFS="/usr/local/sbin/zfs"
-ZED="/usr/local/sbin/zed"
-ZPOOL="/usr/local/sbin/zpool"
-
-When they should have been:
-
-ZFS="/sbin/zfs"
-ZED="/sbin/zed"
-ZPOOL="/sbin/zpool"
-
-This affects init.d (non-systemd) distros like CentOS 6.
-
-Fixes: #9443
-
-Signed-off-by: Tony Hutter <hutter2@llnl.gov>
----
- contrib/initramfs/Makefile.am | 7 ++-----
- 1 file changed, 2 insertions(+), 5 deletions(-)
-
-diff --git a/contrib/initramfs/Makefile.am b/contrib/initramfs/Makefile.am
-index 52bdeb2afe5..4e52e8ea5e9 100644
---- a/contrib/initramfs/Makefile.am
-+++ b/contrib/initramfs/Makefile.am
-@@ -6,15 +6,12 @@ initrd_SCRIPTS = \
- SUBDIRS = hooks scripts
-
- EXTRA_DIST = \
-- $(top_srcdir)/etc/init.d/zfs \
-- $(top_srcdir)/etc/init.d/zfs-functions \
-+ $(top_srcdir)/etc/init.d/zfs.in \
-+ $(top_srcdir)/etc/init.d/zfs-functions.in \
- $(top_srcdir)/contrib/initramfs/conf.d/zfs \
- $(top_srcdir)/contrib/initramfs/conf-hooks.d/zfs \
- $(top_srcdir)/contrib/initramfs/README.initramfs.markdown
-
--$(top_srcdir)/etc/init.d/zfs $(top_srcdir)/etc/init.d/zfs-functions:
-- $(MAKE) -C $(top_srcdir)/etc/init.d zfs zfs-functions
--
- install-initrdSCRIPTS: $(EXTRA_DIST)
- for d in conf.d conf-hooks.d scripts/local-top; do \
- $(MKDIR_P) $(DESTDIR)$(initrddir)/$$d; \
diff --git a/sys-fs/zfs/files/zfs-init.sh.in b/sys-fs/zfs/files/zfs-init.sh.in
deleted file mode 100644
index ed84585cd5f6..000000000000
--- a/sys-fs/zfs/files/zfs-init.sh.in
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/sh
-
-ZFS="@sbindir@/zfs"
-ZPOOL="@sbindir@/zpool"
-ZPOOL_CACHE="@sysconfdir@/zfs/zpool.cache"
-
-if [ -f "${ZPOOL_CACHE}" ]; then
- "${ZPOOL}" import -c "${ZPOOL_CACHE}" -aN 2>/dev/null
- if [ "${?}" != "0" ]; then
- echo "Failed to import not-yet imported pools." >&2
- fi
-fi
-
-echo "Mounting ZFS filesystems"
-"${ZFS}" mount -a
-if [ "${?}" != "0" ]; then
- echo "Failed to mount ZFS filesystems." >&2
- exit 1
-fi
-
-echo "Exporting ZFS filesystems"
-"${ZFS}" share -a
-if [ "${?}" != "0" ]; then
- echo "Failed to export ZFS filesystems." >&2
- exit 1
-fi
-
-exit 0
-
diff --git a/sys-fs/zfs/files/zfs.service.in b/sys-fs/zfs/files/zfs.service.in
deleted file mode 100644
index ae2eff170a72..000000000000
--- a/sys-fs/zfs/files/zfs.service.in
+++ /dev/null
@@ -1,16 +0,0 @@
-[Unit]
-Description=ZFS filesystems setup
-Before=network.target
-After=systemd-udev-settle.target local-fs.target
-
-[Service]
-Type=oneshot
-RemainAfterExit=yes
-ExecStartPre=-/sbin/modprobe zfs
-ExecStartPre=/usr/bin/test -c /dev/zfs
-ExecStart=/usr/libexec/zfs-init.sh
-ExecStop=@sbindir@/zfs umount -a
-
-[Install]
-WantedBy=multi-user.target
-