summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-07 02:56:49 +0100
committerSam James <sam@gentoo.org>2022-06-07 02:59:09 +0100
commit3cca794d0d7256292b0be28aa333f6cf580cb0a2 (patch)
treefefca61b6c8564b80fa87c89f4b6a7b31efa491d /sys-fs
parentapp-admin/sudo: add 1.9.11 (diff)
downloadgentoo-3cca794d0d7256292b0be28aa333f6cf580cb0a2.tar.gz
gentoo-3cca794d0d7256292b0be28aa333f6cf580cb0a2.tar.bz2
gentoo-3cca794d0d7256292b0be28aa333f6cf580cb0a2.zip
sys-fs/eudev: add 3.2.12_pre1 (unkeyworded)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/eudev/Manifest1
-rw-r--r--sys-fs/eudev/eudev-3.2.12_pre1.ebuild245
-rw-r--r--sys-fs/eudev/eudev-9999.ebuild69
3 files changed, 285 insertions, 30 deletions
diff --git a/sys-fs/eudev/Manifest b/sys-fs/eudev/Manifest
index e963c842d82f..1a9350a6ac29 100644
--- a/sys-fs/eudev/Manifest
+++ b/sys-fs/eudev/Manifest
@@ -1 +1,2 @@
DIST eudev-3.2.11.tar.gz 2254373 BLAKE2B cfa6235d6509b751fde93ff2b0961b93c3741458e561a7ad9b07b49a57779627532cff25ad3519e5f79320854fcedfcdc23642ef542505cebcd6b2803067389a SHA512 17b328365913af3e434abe667dd0498c3702a41c6cb66f3793ca2c195b05ac06397b0a401077f81df7dd25193e4eeea13657a221ca6cb3d237c4d91e31e30b33
+DIST eudev-3.2.12_pre1.tar.gz 2304454 BLAKE2B f9f6fd9cb6df6b59afff0ff1bab606ac76f9e944bcb0f5b89370c2ae2e5bfaf69428a0a4eff6460970db83fbaa09ad2e961105ee7a0204f122bf7aabe9fc1e50 SHA512 829513b732d0d2994f6921d0208d477978bfdb09274c9c03e4802f5f6f60f6a245c22d2d59b3efdce4e3c6e5c7a344633776522c001e76d51eb0c48a7f3cca84
diff --git a/sys-fs/eudev/eudev-3.2.12_pre1.ebuild b/sys-fs/eudev/eudev-3.2.12_pre1.ebuild
new file mode 100644
index 000000000000..18823816ad13
--- /dev/null
+++ b/sys-fs/eudev/eudev-3.2.12_pre1.ebuild
@@ -0,0 +1,245 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KV_MIN=2.6.39
+
+inherit autotools linux-info multilib-minimal toolchain-funcs udev
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/eudev-project/eudev.git"
+ inherit git-r3
+else
+ MY_PV=${PV/_pre/-pre}
+ SRC_URI="https://github.com/eudev-project/eudev/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_PV}
+
+ if [[ ${PV} != *_pre* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ fi
+fi
+
+DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
+HOMEPAGE="https://github.com/eudev-project/eudev"
+
+LICENSE="LGPL-2.1 MIT GPL-2"
+SLOT="0"
+IUSE="+kmod rule-generator selinux static-libs test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=sys-apps/util-linux-2.20
+ >=sys-kernel/linux-headers-${KV_MIN}
+ virtual/libcrypt:=
+ kmod? ( >=sys-apps/kmod-16 )
+ selinux? ( >=sys-libs/libselinux-2.1.9 )
+ !sys-apps/gentoo-systemd-integration
+ !sys-apps/systemd"
+RDEPEND="${DEPEND}
+ acct-group/input
+ acct-group/kvm
+ acct-group/render
+ !sys-apps/systemd-utils[udev]
+ !sys-fs/udev
+ !sys-apps/systemd
+ !sys-apps/hwids[udev]"
+BDEPEND="dev-util/gperf
+ virtual/os-headers
+ virtual/pkgconfig
+ test? (
+ app-text/tree
+ dev-lang/perl
+ )"
+PDEPEND=">=sys-fs/udev-init-scripts-26"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/udev.h
+)
+
+pkg_pretend() {
+ ewarn
+ ewarn "As of 2013-01-29, ${PN} provides the new interface renaming functionality,"
+ ewarn "as described in the URL below:"
+ ewarn "https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames"
+ ewarn
+ ewarn "This functionality is enabled BY DEFAULT because eudev has no means of synchronizing"
+ ewarn "between the default or user-modified choice of sys-fs/udev. If you wish to disable"
+ ewarn "this new iface naming, please be sure that /etc/udev/rules.d/80-net-name-slot.rules"
+ ewarn "exists: touch /etc/udev/rules.d/80-net-name-slot.rules"
+ ewarn
+}
+
+pkg_setup() {
+ CONFIG_CHECK="~BLK_DEV_BSG ~DEVTMPFS ~!IDE ~INOTIFY_USER ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2 ~SIGNALFD ~EPOLL ~FHANDLE ~NET ~UNIX"
+ linux-info_pkg_setup
+ get_running_version
+
+ # These are required kernel options, but we don't error out on them
+ # because you can build under one kernel and run under another.
+ if kernel_is lt ${KV_MIN//./ }; then
+ ewarn
+ ewarn "Your current running kernel version ${KV_FULL} is too old to run ${P}."
+ ewarn "Make sure to run udev under kernel version ${KV_MIN} or above."
+ ewarn
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Change rules back to group uucp instead of dialout for now
+ sed -e 's/GROUP="dialout"/GROUP="uucp"/' -i rules/*.rules \
+ || die "failed to change group dialout to uucp"
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # bug #463846
+ tc-export CC
+ # bug #502950
+ export cc_cv_CFLAGS__flto=no
+
+ local myeconfargs=(
+ ac_cv_search_cap_init=
+ ac_cv_header_sys_capability_h=yes
+
+ DBUS_CFLAGS=' '
+ DBUS_LIBS=' '
+
+ --with-rootprefix=
+ --with-rootrundir=/run
+ --exec-prefix="${EPREFIX}"
+ --bindir="${EPREFIX}"/bin
+ --includedir="${EPREFIX}"/usr/include
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --with-rootlibexecdir="${EPREFIX}"/lib/udev
+ --enable-split-usr
+ --enable-manpages
+ )
+
+ # Only build libudev for non-native_abi, and only install it to libdir,
+ # that means all options only apply to native_abi
+ if multilib_is_native_abi ; then
+ myeconfargs+=(
+ --with-rootlibdir="${EPREFIX}"/$(get_libdir)
+ $(use_enable kmod)
+ $(use_enable static-libs static)
+ $(use_enable selinux)
+ $(use_enable rule-generator)
+ )
+ else
+ myeconfargs+=(
+ --disable-static
+ --disable-kmod
+ --disable-selinux
+ --disable-rule-generator
+ --disable-hwdb
+ )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi ; then
+ emake
+ else
+ emake -C src/shared
+ emake -C src/libudev
+ fi
+}
+
+multilib_src_test() {
+ # Make sandbox get out of the way.
+ # These are safe because there is a fake root filesystem put in place,
+ # but sandbox seems to evaluate the paths of the test i/o instead of the
+ # paths of the actual i/o that results. Also only test for native abi
+ if multilib_is_native_abi ; then
+ addread /sys
+ addwrite /dev
+ addwrite /run
+
+ default
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi ; then
+ emake DESTDIR="${D}" install
+ else
+ emake -C src/libudev DESTDIR="${D}" install
+ fi
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+
+ insinto /lib/udev/rules.d
+ doins "${FILESDIR}"/40-gentoo.rules
+
+ use rule-generator && doinitd "${FILESDIR}"/udev-postmount
+}
+
+pkg_postrm() {
+ udev_reload
+}
+
+pkg_postinst() {
+ udev_reload
+
+ mkdir -p "${EROOT}"/run
+
+ # "losetup -f" is confused if there is an empty /dev/loop/, Bug #338766
+ # So try to remove it here (will only work if empty).
+ rmdir "${EROOT}"/dev/loop 2>/dev/null
+ if [[ -d ${EROOT}/dev/loop ]]; then
+ ewarn "Please make sure your remove /dev/loop,"
+ ewarn "else losetup may be confused when looking for unused devices."
+ fi
+
+ # REPLACING_VERSIONS should only ever have zero or 1 values but in case it doesn't,
+ # process it as a list. We only care about the zero case (new install) or the case where
+ # the same version is being re-emerged. If there is a second version, allow it to abort.
+ local rv rvres=doitnew
+ for rv in ${REPLACING_VERSIONS} ; do
+ if [[ ${rvres} == doit* ]]; then
+ if [[ ${rv%-r*} == ${PV} ]]; then
+ rvres=doit
+ else
+ rvres=${rv}
+ fi
+ fi
+ done
+
+ if has_version 'sys-apps/hwids[udev]'; then
+ udevadm hwdb --update --root="${ROOT}"
+
+ # https://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ # reload database after it has be rebuilt, but only if we are not upgrading
+ # also pass if we are -9999 since who knows what hwdb related changes there might be
+ if [[ ${rvres} == doit* ]] && [[ -z ${ROOT} ]] && [[ ${PV} != "9999" ]]; then
+ udevadm control --reload
+ fi
+ fi
+
+ if [[ ${rvres} != doitnew ]]; then
+ ewarn
+ ewarn "You need to restart eudev as soon as possible to make the"
+ ewarn "upgrade go into effect:"
+ ewarn "\t/etc/init.d/udev --nodeps restart"
+ fi
+
+ if use rule-generator && \
+ [[ -x $(type -P rc-update) ]] && rc-update show | grep udev-postmount | grep -qsv 'boot\|default\|sysinit'; then
+ ewarn
+ ewarn "Please add the udev-postmount init script to your default runlevel"
+ ewarn "to ensure the legacy rule-generator functionality works as reliably"
+ ewarn "as possible."
+ ewarn "\trc-update add udev-postmount default"
+ fi
+
+ elog
+ elog "For more information on eudev on Gentoo, writing udev rules, and"
+ elog "fixing known issues visit: https://wiki.gentoo.org/wiki/Eudev"
+}
diff --git a/sys-fs/eudev/eudev-9999.ebuild b/sys-fs/eudev/eudev-9999.ebuild
index a4edb4657be9..18823816ad13 100644
--- a/sys-fs/eudev/eudev-9999.ebuild
+++ b/sys-fs/eudev/eudev-9999.ebuild
@@ -1,32 +1,36 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
KV_MIN=2.6.39
-inherit autotools linux-info multilib-minimal toolchain-funcs
+inherit autotools linux-info multilib-minimal toolchain-funcs udev
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/eudev-project/eudev.git"
inherit git-r3
else
- SRC_URI="https://github.com/eudev-project/eudev/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ MY_PV=${PV/_pre/-pre}
+ SRC_URI="https://github.com/eudev-project/eudev/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_PV}
+
+ if [[ ${PV} != *_pre* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ fi
fi
DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
-HOMEPAGE="https://github.com/gentoo/eudev"
+HOMEPAGE="https://github.com/eudev-project/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
-IUSE="+kmod introspection rule-generator selinux static-libs test"
+IUSE="+kmod rule-generator selinux static-libs test"
RESTRICT="!test? ( test )"
DEPEND=">=sys-apps/util-linux-2.20
>=sys-kernel/linux-headers-${KV_MIN}
virtual/libcrypt:=
- introspection? ( >=dev-libs/gobject-introspection-1.38 )
kmod? ( >=sys-apps/kmod-16 )
selinux? ( >=sys-libs/libselinux-2.1.9 )
!sys-apps/gentoo-systemd-integration
@@ -42,8 +46,10 @@ RDEPEND="${DEPEND}
BDEPEND="dev-util/gperf
virtual/os-headers
virtual/pkgconfig
- >=sys-devel/make-3.82-r4
- test? ( app-text/tree dev-lang/perl )"
+ test? (
+ app-text/tree
+ dev-lang/perl
+ )"
PDEPEND=">=sys-fs/udev-init-scripts-26"
MULTILIB_WRAPPED_HEADERS=(
@@ -52,7 +58,7 @@ MULTILIB_WRAPPED_HEADERS=(
pkg_pretend() {
ewarn
- ewarn "As of 2013-01-29, ${P} provides the new interface renaming functionality,"
+ ewarn "As of 2013-01-29, ${PN} provides the new interface renaming functionality,"
ewarn "as described in the URL below:"
ewarn "https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames"
ewarn
@@ -79,11 +85,12 @@ pkg_setup() {
}
src_prepare() {
- # change rules back to group uucp instead of dialout for now
+ default
+
+ # Change rules back to group uucp instead of dialout for now
sed -e 's/GROUP="dialout"/GROUP="uucp"/' -i rules/*.rules \
|| die "failed to change group dialout to uucp"
- default
eautoreconf
}
@@ -93,14 +100,13 @@ multilib_src_configure() {
# bug #502950
export cc_cv_CFLAGS__flto=no
- # Keep sorted by ./configure --help and only pass --disable flags
- # when *required* to avoid external deps or unnecessary compile
- local econf_args
- econf_args=(
+ local myeconfargs=(
ac_cv_search_cap_init=
ac_cv_header_sys_capability_h=yes
+
DBUS_CFLAGS=' '
DBUS_LIBS=' '
+
--with-rootprefix=
--with-rootrundir=/run
--exec-prefix="${EPREFIX}"
@@ -114,19 +120,17 @@ multilib_src_configure() {
# Only build libudev for non-native_abi, and only install it to libdir,
# that means all options only apply to native_abi
- if multilib_is_native_abi; then
- econf_args+=(
+ if multilib_is_native_abi ; then
+ myeconfargs+=(
--with-rootlibdir="${EPREFIX}"/$(get_libdir)
- $(use_enable introspection)
$(use_enable kmod)
$(use_enable static-libs static)
$(use_enable selinux)
$(use_enable rule-generator)
)
else
- econf_args+=(
+ myeconfargs+=(
--disable-static
- --disable-introspection
--disable-kmod
--disable-selinux
--disable-rule-generator
@@ -134,11 +138,11 @@ multilib_src_configure() {
)
fi
- ECONF_SOURCE="${S}" econf "${econf_args[@]}"
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_compile() {
- if multilib_is_native_abi; then
+ if multilib_is_native_abi ; then
emake
else
emake -C src/shared
@@ -147,22 +151,21 @@ multilib_src_compile() {
}
multilib_src_test() {
- # make sandbox get out of the way
- # these are safe because there is a fake root filesystem put in place,
+ # Make sandbox get out of the way.
+ # These are safe because there is a fake root filesystem put in place,
# but sandbox seems to evaluate the paths of the test i/o instead of the
- # paths of the actual i/o that results.
- # also only test for native abi
- if multilib_is_native_abi; then
+ # paths of the actual i/o that results. Also only test for native abi
+ if multilib_is_native_abi ; then
addread /sys
addwrite /dev
addwrite /run
- default_src_test
+ default
fi
}
multilib_src_install() {
- if multilib_is_native_abi; then
+ if multilib_is_native_abi ; then
emake DESTDIR="${D}" install
else
emake -C src/libudev DESTDIR="${D}" install
@@ -178,7 +181,13 @@ multilib_src_install_all() {
use rule-generator && doinitd "${FILESDIR}"/udev-postmount
}
+pkg_postrm() {
+ udev_reload
+}
+
pkg_postinst() {
+ udev_reload
+
mkdir -p "${EROOT}"/run
# "losetup -f" is confused if there is an empty /dev/loop/, Bug #338766