summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-03-29 20:01:32 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-03-29 20:03:00 -0400
commit42d370f628d41c3297c2efaaae197cef74fe80d8 (patch)
tree8db36e490135cfb6414bb5fcd0e7998dc1e02624 /sys-fs
parentapp-text/sigil: cosmetic fixes 0.9.4 (diff)
downloadgentoo-42d370f628d41c3297c2efaaae197cef74fe80d8.tar.gz
gentoo-42d370f628d41c3297c2efaaae197cef74fe80d8.tar.bz2
gentoo-42d370f628d41c3297c2efaaae197cef74fe80d8.zip
sys-fs/encfs: add libressl support
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/encfs/encfs-1.8.1-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-fs/encfs/encfs-1.8.1-r1.ebuild b/sys-fs/encfs/encfs-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..de939a370bf3
--- /dev/null
+++ b/sys-fs/encfs/encfs-1.8.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit autotools eutils multilib
+
+DESCRIPTION="An implementation of encrypted filesystem in user-space using FUSE"
+HOMEPAGE="https://vgough.github.io/encfs/"
+SRC_URI="https://github.com/vgough/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE="xattr nls libressl"
+
+RDEPEND="dev-libs/boost:=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ dev-libs/rlog
+ sys-fs/fuse
+ sys-libs/zlib"
+# Your libc probably provides xattrs, but to be safe
+# we'll dep on sys-apps/attr. This should be fixed
+# if we ever create a virtual/attr.
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ xattr? ( sys-apps/attr )
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # configure searches for either attr/xattr.h or sys/xattr.h
+ use xattr || export ac_cv_header_{attr,sys}_xattr_h=no
+
+ econf \
+ $(use_enable nls) \
+ --disable-valgrind \
+ --enable-openssl \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README.md
+ find "${D}" -name '*.la' -delete
+}