summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-08-17 02:33:18 +0300
committerLars Wendler <polynomial-c@gentoo.org>2019-08-27 09:28:48 +0200
commit4ea95c8cdc5213b05dc062806744605c5832dec6 (patch)
tree21ae638a8c878787175a198292825f9a176ee98c /sys-fs
parentdev-ada/gprbuild: remove unused version (diff)
downloadgentoo-4ea95c8cdc5213b05dc062806744605c5832dec6.tar.gz
gentoo-4ea95c8cdc5213b05dc062806744605c5832dec6.tar.bz2
gentoo-4ea95c8cdc5213b05dc062806744605c5832dec6.zip
sys-fs/cryptsetup: remove USE=libressl from REQUIRED_USE
USE=libressl must not be mutually exclusive to USE=openssl or any other USE flag. Also USE=openssl must be enabled when using USE=libressl, so that dependencies are checked correctly. Closes: https://bugs.gentoo.org/692314 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Stefan Strogin <steils@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/12728 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild b/sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild
index 49cad800b719..8cb062389bc5 100644
--- a/sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild
@@ -13,13 +13,12 @@ LICENSE="GPL-2+"
SLOT="0/12" # libcryptsetup.so version
[[ ${PV} != *_rc* ]] && \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-# cryptsetup does _not_ have a libressl backend. We only have this for REQUIRED_USE
-# and change "libressl" to "openssl" in our econf call.
-CRYPTO_BACKENDS="gcrypt kernel libressl nettle +openssl"
+CRYPTO_BACKENDS="gcrypt kernel nettle +openssl"
# we don't support nss since it doesn't allow cryptsetup to be built statically
# and it's missing ripemd160 support so it can't provide full backward compatibility
IUSE="${CRYPTO_BACKENDS} +argon2 libressl +luks1_default nls pwquality reencrypt static static-libs +udev urandom"
REQUIRED_USE="^^ ( ${CRYPTO_BACKENDS//+/} )
+ libressl? ( openssl )
static? ( !gcrypt )" #496612
LIB_DEPEND="
@@ -32,7 +31,7 @@ LIB_DEPEND="
nettle? ( >=dev-libs/nettle-2.4[static-libs(+)] )
openssl? (
!libressl? ( dev-libs/openssl:0=[static-libs(+)] )
- libressl? ( dev-libs/libressl:=[static-libs(+)] )
+ libressl? ( dev-libs/libressl:0=[static-libs(+)] )
)
pwquality? ( dev-libs/libpwquality[static-libs(+)] )
sys-fs/lvm2[static-libs(+)]
@@ -83,11 +82,6 @@ src_configure() {
ewarn "userspace crypto libraries."
fi
- local x cryptobackend
- for x in ${CRYPTO_BACKENDS//+/} ; do
- use ${x} && cryptobackend="${x/libressl/openssl}"
- done
-
local myeconfargs=(
--disable-internal-argon2
--enable-shared
@@ -95,7 +89,7 @@ src_configure() {
# for later use
--with-default-luks-format=LUKS$(usex luks1_default 1 2)
--with-tmpfilesdir="${EPREFIX}/usr/lib/tmpfiles.d"
- --with-crypto_backend=${cryptobackend}
+ --with-crypto_backend=$(for x in ${CRYPTO_BACKENDS//+/} ; do usev ${x} ; done)
$(use_enable argon2 libargon2)
$(use_enable nls)
$(use_enable pwquality)