summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-23 20:18:13 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-23 20:19:06 -0600
commit528e791dd8af2e5c84f0e34398334c0c0770b07c (patch)
tree01b2f3c8f8ea0017d495a18806e008446a186583 /sys-fs
parentmedia-sound/musescore: Fix build with Qt 5.12 (diff)
downloadgentoo-528e791dd8af2e5c84f0e34398334c0c0770b07c.tar.gz
gentoo-528e791dd8af2e5c84f0e34398334c0c0770b07c.tar.bz2
gentoo-528e791dd8af2e5c84f0e34398334c0c0770b07c.zip
sys-fs/clamfs: use slotted sys-fs/fuse dep
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/clamfs/clamfs-1.0.1-r3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-fs/clamfs/clamfs-1.0.1-r3.ebuild b/sys-fs/clamfs/clamfs-1.0.1-r3.ebuild
new file mode 100644
index 000000000000..8a8bf827a5ba
--- /dev/null
+++ b/sys-fs/clamfs/clamfs-1.0.1-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit eutils linux-info
+
+DESCRIPTION="A FUSE-based user-space file system with on-access anti-virus file scanning"
+HOMEPAGE="http://clamfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.33
+ sys-fs/fuse:0
+ dev-cpp/commoncpp2
+ dev-libs/rlog
+ dev-libs/poco"
+RDEPEND="${DEPEND}
+ app-antivirus/clamav"
+
+CONFIG_CHECK="~FUSE_FS"
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-gentoo.patch"
+ eapply -p0 "${FILESDIR}/${P}-gcc45.patch"
+ eapply_user
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ insinto /etc/clamfs
+ doins doc/clamfs.xml
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}