summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-06-29 13:08:49 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-06-29 13:22:37 -0400
commit6445ffa1263302c384b33765aa711a59b133b4dd (patch)
treead785615622e07d9f76b973e21758a562238ebb9 /sys-fs
parentsys-fs/inotify-tools: fix build with musl (diff)
downloadgentoo-6445ffa1263302c384b33765aa711a59b133b4dd.tar.gz
gentoo-6445ffa1263302c384b33765aa711a59b133b4dd.tar.bz2
gentoo-6445ffa1263302c384b33765aa711a59b133b4dd.zip
sys-fs/inotify-tools: tidy a bit
datarootdir trick was shorter/interesting but it also feel a bit too unusual for ebuilds Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild b/sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild
index 6a270595ec4e..8a96f1e65ec8 100644
--- a/sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild
+++ b/sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild
@@ -5,9 +5,9 @@ EAPI=8
inherit autotools
-DESCRIPTION="a set of command-line programs providing a simple interface to inotify"
-HOMEPAGE="https://github.com/inotify-tools/inotify-tools"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="https://github.com/inotify-tools/inotify-tools/"
+SRC_URI="https://github.com/inotify-tools/inotify-tools/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -23,24 +23,22 @@ PATCHES=(
src_prepare() {
default
- # Remove -Werror from CFLAGS (#745069)
- find -name "Makefile.am" -print0 \
- | xargs --null sed 's@ -Werror@@' -i || die
+ sed -i 's/ -Werror//' {,libinotifytools/}src/Makefile.am || die #745069
eautoreconf
}
src_configure() {
- # only docs installed are doxygen ones, so use /html
- local myeconfargs=(
- --disable-static
- --docdir='$(datarootdir)'/doc/${PF}/html
+ local econfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
$(use_enable doc doxygen)
)
- econf "${myeconfargs[@]}"
+
+ econf "${econfargs[@]}"
}
src_install() {
default
+
find "${ED}" -type f -name '*.la' -delete || die
}