summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-08-04 19:44:40 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-08-04 19:50:39 +0300
commit64d48ce1393df59ffe1d93e328f70da074bc9514 (patch)
treefd76bd12d7a3ddc9e65756ce5c00d7c83d76be6d /sys-fs
parentx11-terms/terminology: bump to 1.8.0 (diff)
downloadgentoo-64d48ce1393df59ffe1d93e328f70da074bc9514.tar.gz
gentoo-64d48ce1393df59ffe1d93e328f70da074bc9514.tar.bz2
gentoo-64d48ce1393df59ffe1d93e328f70da074bc9514.zip
sys-fs/lxcfs: bump to 4.0.5
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lxcfs/Manifest1
-rw-r--r--sys-fs/lxcfs/lxcfs-4.0.5.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-fs/lxcfs/Manifest b/sys-fs/lxcfs/Manifest
index 1eb6648b2c62..b2286fe267fa 100644
--- a/sys-fs/lxcfs/Manifest
+++ b/sys-fs/lxcfs/Manifest
@@ -1,2 +1,3 @@
DIST lxcfs-4.0.3.tar.gz 100719 BLAKE2B 24371b921ad635f97c51ac8406c949e81330ae358b0166c2af295cb1f630594bb72da802aad41971c11303f393fd05bc9f1b109bd4da4953db2c3bb7e5189315 SHA512 0aaedfe826d982b9464dfb60fb57c58e34ea6022b8503bc858538b6634dc7d0845f65832d6f814043dbc0677f887e1b559549a8f3865c755970c6b47ba65eb2b
DIST lxcfs-4.0.4.tar.gz 101546 BLAKE2B 1e84e3b75bfb39273539ea72f941442cc3c8574c0f55359a38edc04a98a45ea8680f9bf49c5974decf180a8ecf07cadccf4e732d1743c070a740c78b773a3ee8 SHA512 15bcebecc815310870aea58d995d605444b57583b7f1bb2d35b065256ea5f70b071d58887fbf1ca124ea84da99151bbd9dffcca37a2e151677d56229dc8961ce
+DIST lxcfs-4.0.5.tar.gz 101842 BLAKE2B c916473e1b7ad42b8f69026a16810941c999d44ffcf1d456cb301411965f05e626338a5bde1e38fe99acd05f72bbcd5acbdcb2f65fa5ec183c967babcb8c70fd SHA512 5c44aa7f43071a4316cc8702928fde2c928bd5654c9ab4d540152839db0d7dd235a861f263da56f02611941d46d22eee98e0cdd52aeaeda99f3c79c754d420a1
diff --git a/sys-fs/lxcfs/lxcfs-4.0.5.ebuild b/sys-fs/lxcfs/lxcfs-4.0.5.ebuild
new file mode 100644
index 000000000000..3f5a924ec104
--- /dev/null
+++ b/sys-fs/lxcfs/lxcfs-4.0.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="FUSE filesystem for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/ https://github.com/lxc/lxcfs/"
+SRC_URI="https://github.com/lxc/lxcfs/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/glib:2
+ sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/help2man"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Without the localstatedir the filesystem isn't mounted correctly
+ # Without with-distro ./configure will fail when cross-compiling
+ econf --localstatedir=/var --with-distro=gentoo
+}
+
+src_test() {
+ cd tests/ || die
+ emake tests
+ ./main.sh || die "Tests failed"
+}
+
+src_install() {
+ default
+
+ newconfd "${FILESDIR}"/lxcfs-4.0.0.confd lxcfs
+ newinitd "${FILESDIR}"/lxcfs-4.0.0.initd lxcfs
+
+ # Provide our own service file (copy of upstream) due to paths being different from upstream,
+ # 728470
+ systemd_newunit "${FILESDIR}"/lxcfs-4.0.0.service lxcfs.service
+}