summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorautomorphism88 <adebeus@gmail.com>2018-03-27 12:34:26 -0700
committerMichał Górny <mgorny@gentoo.org>2018-03-30 23:52:54 +0200
commit6b6d7b9052d7572e3cebc1b59877a347b368cd89 (patch)
treeb7af7e78f68d0dd51e4aa3b70ffb3b69189b6515 /sys-fs
parentdev-db/mariadb: Version bump for 10.1.32 (diff)
downloadgentoo-6b6d7b9052d7572e3cebc1b59877a347b368cd89.tar.gz
gentoo-6b6d7b9052d7572e3cebc1b59877a347b368cd89.tar.bz2
gentoo-6b6d7b9052d7572e3cebc1b59877a347b368cd89.zip
sys-fs/compsize: New ebuild
Closes: https://github.com/gentoo/gentoo/pull/7660
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/compsize/Manifest1
-rw-r--r--sys-fs/compsize/compsize-1.1.ebuild41
-rw-r--r--sys-fs/compsize/compsize-9999.ebuild41
-rw-r--r--sys-fs/compsize/metadata.xml11
4 files changed, 94 insertions, 0 deletions
diff --git a/sys-fs/compsize/Manifest b/sys-fs/compsize/Manifest
new file mode 100644
index 000000000000..a60978e46f22
--- /dev/null
+++ b/sys-fs/compsize/Manifest
@@ -0,0 +1 @@
+DIST compsize-1.1.tar.gz 14345 BLAKE2B 8b35e6f3526b8b2395972ea1a595011b867fbc076d79c90c66a19853f1b101dbe3decedab8244d893b20d6cc9ff3ecfa2b3320fc12c583415b2d446a9298fcb1 SHA512 1c7de5156b695ffa4be9b634fd6224214d3de1653eb23e5d85b250e27146fe655883bed17ed458bae1b448ed9ae8a254d2a673fdb3860e69c99f8676daea0d8b
diff --git a/sys-fs/compsize/compsize-1.1.ebuild b/sys-fs/compsize/compsize-1.1.ebuild
new file mode 100644
index 000000000000..ad73046823bd
--- /dev/null
+++ b/sys-fs/compsize/compsize-1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="Utility to find btrfs compression ratio"
+HOMEPAGE="https://github.com/kilobyte/compsize"
+
+if [[ ${PV} = 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kilobyte/compsize"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kilobyte/compsize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2+"
+SLOT=0
+
+RDEPEND=""
+DEPEND="sys-fs/btrfs-progs"
+
+src_prepare() {
+ eapply_user
+ # Don't try to install a gzipped manfile during make install, instead
+ # use doman in src_install to ensure that PORTAGE_COMPRESS is used
+ sed -i $'/^\tgzip /d' Makefile || die
+}
+
+src_configure() {
+ # Used in upstream Makefile, but clobbered by portage's CFLAGS
+ append-cflags -Wall -std=gnu90
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED%/}" install
+ doman compsize.8
+ einstalldocs
+}
diff --git a/sys-fs/compsize/compsize-9999.ebuild b/sys-fs/compsize/compsize-9999.ebuild
new file mode 100644
index 000000000000..ad73046823bd
--- /dev/null
+++ b/sys-fs/compsize/compsize-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="Utility to find btrfs compression ratio"
+HOMEPAGE="https://github.com/kilobyte/compsize"
+
+if [[ ${PV} = 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kilobyte/compsize"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kilobyte/compsize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2+"
+SLOT=0
+
+RDEPEND=""
+DEPEND="sys-fs/btrfs-progs"
+
+src_prepare() {
+ eapply_user
+ # Don't try to install a gzipped manfile during make install, instead
+ # use doman in src_install to ensure that PORTAGE_COMPRESS is used
+ sed -i $'/^\tgzip /d' Makefile || die
+}
+
+src_configure() {
+ # Used in upstream Makefile, but clobbered by portage's CFLAGS
+ append-cflags -Wall -std=gnu90
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED%/}" install
+ doman compsize.8
+ einstalldocs
+}
diff --git a/sys-fs/compsize/metadata.xml b/sys-fs/compsize/metadata.xml
new file mode 100644
index 000000000000..7f4384fb84c6
--- /dev/null
+++ b/sys-fs/compsize/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>adebeus@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>