summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-09-23 21:27:47 +0200
committerPacho Ramos <pacho@gentoo.org>2016-09-23 21:30:25 +0200
commit9de7d87e87c1620e47287d65d9c75dffce150d80 (patch)
treed25cff923800ea51c60b5069c2ac217b062519c4 /sys-fs
parentwww-servers/tornado: Version bump (diff)
downloadgentoo-9de7d87e87c1620e47287d65d9c75dffce150d80.tar.gz
gentoo-9de7d87e87c1620e47287d65d9c75dffce150d80.tar.bz2
gentoo-9de7d87e87c1620e47287d65d9c75dffce150d80.zip
sys-fs/e4rat: Fix compilation with gcc6 (#594046 by Peter Levine)
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e4rat/e4rat-0.2.4_pre20141201.ebuild12
-rw-r--r--sys-fs/e4rat/files/e4rat-0.2.4-gcc6.patch11
2 files changed, 16 insertions, 7 deletions
diff --git a/sys-fs/e4rat/e4rat-0.2.4_pre20141201.ebuild b/sys-fs/e4rat/e4rat-0.2.4_pre20141201.ebuild
index 7bbee6565e1f..5c62fd26a713 100644
--- a/sys-fs/e4rat/e4rat-0.2.4_pre20141201.ebuild
+++ b/sys-fs/e4rat/e4rat-0.2.4_pre20141201.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-
-inherit cmake-utils linux-info readme.gentoo
+EAPI=6
+inherit cmake-utils linux-info readme.gentoo-r1
DESCRIPTION="Toolset to accelerate the boot process and application startup"
HOMEPAGE="http://e4rat.sourceforge.net/"
@@ -23,9 +22,7 @@ RDEPEND="
sys-process/audit
sys-process/lsof
"
-DEPEND="${DEPEND}
- app-arch/xz-utils
-"
+DEPEND="${DEPEND}"
CONFIG_CHECK="~AUDITSYSCALL"
@@ -33,6 +30,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.2.2-shared-build.patch
"${FILESDIR}"/${PN}-0.2.2-libdir.patch
"${FILESDIR}"/${PN}-0.2.4-sysmacros.patch #580534
+ "${FILESDIR}"/${PN}-0.2.4-gcc6.patch #594046
)
pkg_setup() {
diff --git a/sys-fs/e4rat/files/e4rat-0.2.4-gcc6.patch b/sys-fs/e4rat/files/e4rat-0.2.4-gcc6.patch
new file mode 100644
index 000000000000..cdf14e5c92eb
--- /dev/null
+++ b/sys-fs/e4rat/files/e4rat-0.2.4-gcc6.patch
@@ -0,0 +1,11 @@
+--- e4rat-0.2.4_pre20141201/src/logging.hh.old 2016-09-21 22:01:37.631925077 -0400
++++ e4rat-0.2.4_pre20141201/src/logging.hh 2016-09-21 22:01:44.351086734 -0400
+@@ -93,7 +93,7 @@
+ #define dump_log(...) logger.write(__VA_ARGS__)
+
+ #ifdef DEBUG_ENABLED
+- #define debug(format,args...) dump_log(Debug, "%s:%d in %s(): "format, __FILE__, __LINE__, __FUNCTION__, ## args)
++ #define debug(format,args...) dump_log(Debug, "%s:%d in %s(): " format, __FILE__, __LINE__, __FUNCTION__, ## args)
+ #else
+ #define debug(format,args...)
+ #endif