summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-14 08:02:21 +0000
committerSam James <sam@gentoo.org>2021-11-14 08:02:36 +0000
commitac2e319813282c3a79c1a704aee66387bc10a149 (patch)
treef9f6029632d761aee977666fad9ef52e44beef2a /sys-fs
parentdev-python/gast: Bump to 0.5.3 (diff)
downloadgentoo-ac2e319813282c3a79c1a704aee66387bc10a149.tar.gz
gentoo-ac2e319813282c3a79c1a704aee66387bc10a149.tar.bz2
gentoo-ac2e319813282c3a79c1a704aee66387bc10a149.zip
sys-fs/udev: fix build with linux-headers-5.15
Just like tmpfiles and systemd itself. Closes: https://bugs.gentoo.org/821550 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/files/249-udev-linux-headers-5-15.patch22
-rw-r--r--sys-fs/udev/udev-249-r3.ebuild1
2 files changed, 23 insertions, 0 deletions
diff --git a/sys-fs/udev/files/249-udev-linux-headers-5-15.patch b/sys-fs/udev/files/249-udev-linux-headers-5-15.patch
new file mode 100644
index 000000000000..844099b72819
--- /dev/null
+++ b/sys-fs/udev/files/249-udev-linux-headers-5-15.patch
@@ -0,0 +1,22 @@
+https://github.com/systemd/systemd-stable/pull/132/commits/92bbfcdc733d39ec4097d8678bc92a7aaaf78ae1.patch
+https://bugs.gentoo.org/821550
+
+From: Chris Packham <chris.packham@alliedtelesis.co.nz>
+Date: Fri, 10 Sep 2021 09:51:36 +1200
+Subject: [PATCH 1/2] basic/linux: Sync if_arp.h with Linux 5.14
+
+ARPHRD_MCTP was added in 5.14. Sync if_arp.h to pick up the definition
+
+Fixes #20694
+
+(cherry picked from commit 7c5b9952c4f6e2b72f90edbe439982528b7cf223)
+--- a/src/basic/linux/if_arp.h
++++ b/src/basic/linux/if_arp.h
+@@ -54,6 +54,7 @@
+ #define ARPHRD_X25 271 /* CCITT X.25 */
+ #define ARPHRD_HWX25 272 /* Boards with X.25 in firmware */
+ #define ARPHRD_CAN 280 /* Controller Area Network */
++#define ARPHRD_MCTP 290
+ #define ARPHRD_PPP 512
+ #define ARPHRD_CISCO 513 /* Cisco HDLC */
+ #define ARPHRD_HDLC ARPHRD_CISCO
diff --git a/sys-fs/udev/udev-249-r3.ebuild b/sys-fs/udev/udev-249-r3.ebuild
index 2e1601d89e08..d8c084d97863 100644
--- a/sys-fs/udev/udev-249-r3.ebuild
+++ b/sys-fs/udev/udev-249-r3.ebuild
@@ -116,6 +116,7 @@ src_prepare() {
# backport from 250 to silence musl warnings
"${FILESDIR}/249-sys-include-posix.patch"
"${FILESDIR}/249-libudev-static.patch"
+ "${FILESDIR}/249-udev-linux-headers-5-15.patch"
)
use elibc_musl && PATCHES+=( "${WORKDIR}"/musl-patches )