summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-24 01:32:43 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-25 13:27:56 -0600
commitad5d4a229e505a2b53ca4ea44dc267102e91a3a0 (patch)
tree5b7bdd47a0c2e6f8e85c40da349a0b71a3b21c28 /sys-fs
parentdev-libs/openssl: Fixed parallel install (diff)
downloadgentoo-ad5d4a229e505a2b53ca4ea44dc267102e91a3a0.tar.gz
gentoo-ad5d4a229e505a2b53ca4ea44dc267102e91a3a0.tar.bz2
gentoo-ad5d4a229e505a2b53ca4ea44dc267102e91a3a0.zip
sys-fs/avfs: version bump to 1.0.6
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/avfs/Manifest1
-rw-r--r--sys-fs/avfs/avfs-1.0.6.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-fs/avfs/Manifest b/sys-fs/avfs/Manifest
index 8a9961b4ac47..92e322d8d1d5 100644
--- a/sys-fs/avfs/Manifest
+++ b/sys-fs/avfs/Manifest
@@ -1,2 +1,3 @@
DIST avfs-1.0.4.tar.bz2 719761 BLAKE2B 6bbe47136a6aedd399800ea3ee16f82c367e11f723785ebacf4ef7bd12319ad2f8fe528580e20f368934423ee41afc75b9a73ce7389a100f70e42180e2fb2dcc SHA512 3cfda7a471b5e696984acf9101312e898bc68fe16196bfee8e6a255bd182c279a6ad53fee09c0d6554a968f837e97652e95d794fa46f0d384dd41ae426d49516
DIST avfs-1.0.5.tar.bz2 723937 BLAKE2B 49a7ba0f88e126804c8ae12d1ad9a2924311198baee85f56a17c1e9dd810bdac8d519f0fc8a8cf23b5e4d7319460108e3e27cb28a1dc7320760c42f7257460d0 SHA512 d50d8fc31a56a0dac17a14c19de3f1bae2519feb965768810d19192eba6dbe24ab181c4574ff8982883d9b76f77241a1e27f3ef12d05ab8112f3caf14e59bd3c
+DIST avfs-1.0.6.tar.bz2 729592 BLAKE2B 41c703e92921ba9393d95455f7d3dd18587b2d7f2ff46de02d290515cf6c8182d19ff117a7ce040ccaab491240b4f27a3ebd58026045ae9b0d69f47a8beeabc7 SHA512 6b9c070896c5d5abbb6a8c14a7dfd39d9b58d13a6db122b5bf1756b2da7435dfbc00a1fd04bedf99b94b76d9ec7f8c05fccc21de6b9e713fc60cfe0ec88064b4
diff --git a/sys-fs/avfs/avfs-1.0.6.ebuild b/sys-fs/avfs/avfs-1.0.6.ebuild
new file mode 100644
index 000000000000..155b11e19c13
--- /dev/null
+++ b/sys-fs/avfs/avfs-1.0.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files"
+HOMEPAGE="https://sourceforge.net/projects/avf"
+SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="static-libs +lzma"
+
+RDEPEND=">=sys-fs/fuse-2.4:0
+ sys-libs/zlib
+ app-arch/bzip2
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-fuse \
+ --enable-library \
+ --enable-shared \
+ --with-system-zlib \
+ --with-system-bzlib \
+ $(use_enable static-libs static) \
+ $(use_with lzma xz)
+}
+
+src_install() {
+ default
+
+ # remove cruft
+ rm "${D}"/usr/bin/{davpass,ftppass} || die
+
+ # install docs
+ dodoc doc/{api-overview,background,FORMAT,INSTALL.*,README.avfs-fuse}
+ dosym ../../../$(get_libdir)/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+
+ docinto scripts
+ dodoc scripts/{avfscoda*,*pass}
+
+ find "${ED}" -name "*.la" -delete || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ einfo "This version of AVFS includes FUSE support. It is user-based."
+ einfo "To execute:"
+ einfo "1) as user, mkdir ~/.avfs"
+ einfo "2) make sure fuse is either compiled into the kernel OR"
+ einfo " modprobe fuse or add to startup."
+ einfo "3) run mountavfs"
+ einfo "To unload daemon, type umountavfs"
+ einfo
+ einfo "READ the documentation! Enjoy :)"
+ fi
+}