summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-09-04 19:34:19 +0200
committerDavid Seifert <soap@gentoo.org>2021-09-04 19:34:19 +0200
commitb96fc81d63111dd856fc4b30711b2fe4ab3f53d4 (patch)
treedb459fb568c2bd9d5eafc78d4be68ba3ecc0aa19 /sys-fs
parentsys-fs/exfatprogs: drop 1.1.1 (diff)
downloadgentoo-b96fc81d63111dd856fc4b30711b2fe4ab3f53d4.tar.gz
gentoo-b96fc81d63111dd856fc4b30711b2fe4ab3f53d4.tar.bz2
gentoo-b96fc81d63111dd856fc4b30711b2fe4ab3f53d4.zip
sys-fs/multipath-tools: drop 0.8.6
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.8.6.ebuild92
1 files changed, 0 insertions, 92 deletions
diff --git a/sys-fs/multipath-tools/multipath-tools-0.8.6.ebuild b/sys-fs/multipath-tools/multipath-tools-0.8.6.ebuild
deleted file mode 100644
index 490dda93c853..000000000000
--- a/sys-fs/multipath-tools/multipath-tools-0.8.6.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit linux-info systemd toolchain-funcs udev
-
-DESCRIPTION="Device mapper target autoconfig"
-HOMEPAGE="http://christophe.varoqui.free.fr/"
-SRC_URI="https://github.com/opensvc/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ppc64 x86"
-IUSE="systemd rbd"
-
-BDEPEND="virtual/pkgconfig"
-
-RDEPEND="
- dev-libs/json-c:=
- dev-libs/libaio
- dev-libs/userspace-rcu:=
- >=sys-fs/lvm2-2.02.45
- >=virtual/libudev-232-r3
- sys-libs/readline:0=
- rbd? ( sys-cluster/ceph )
- systemd? ( sys-apps/systemd )
-"
-
-DEPEND="${RDEPEND}"
-
-CONFIG_CHECK="~DM_MULTIPATH"
-
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.8.5-respect-flags.patch
-)
-
-get_systemd_pv() {
- use systemd && \
- $(tc-getPKG_CONFIG) --modversion systemd
-}
-
-src_prepare() {
- default
-
- # The upstream lacks any way to configure the build at present
- # and ceph is a huge dependency, so we're using sed to make it
- # optional until the upstream has a proper configure system
- if ! use rbd ; then
- sed \
- -e "s/libcheckrbd.so/# libcheckrbd.so/" \
- -e "s/-lrados//" \
- -i libmultipath/checkers/Makefile \
- || die
- fi
-}
-
-src_compile() {
- # LIBDM_API_FLUSH involves grepping files in /usr/include,
- # so force the test to go the way we want #411337.
- emake \
- CC="$(tc-getCC)" \
- LIBDM_API_FLUSH=1 SYSTEMD="$(get_systemd_pv)"
-}
-
-src_install() {
- dodir /sbin /usr/share/man/man{3,5,8}
- emake \
- DESTDIR="${D}" \
- RUN=run \
- SYSTEMD=$(get_systemd_pv) \
- unitdir="$(systemd_get_systemunitdir)" \
- libudevdir='${prefix}'/"$(get_udevdir)" \
- pkgconfdir='${prefix}'/usr/'${LIB}'/pkgconfig \
- install
-
- newinitd "${FILESDIR}"/multipathd-r1.rc multipathd
- newinitd "${FILESDIR}"/multipath.rc multipath
-
- einstalldocs
-
- find "${ED}" -type f -name "*.la" -delete || die
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog "If you need multipath on your system, you must"
- elog "add 'multipath' into your boot runlevel!"
- fi
-}