summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-11-06 20:23:30 -0400
committerMike Gilbert <floppym@gentoo.org>2021-11-06 20:28:47 -0400
commitbe0aafde743046bdfac23126b7f264589cf4bc18 (patch)
tree05c5a8b73d79d84bdb26119f1c6dbaced2a48399 /sys-fs
parentsys-fs/ntfs3g: actually make USE=suid do something (diff)
downloadgentoo-be0aafde743046bdfac23126b7f264589cf4bc18.tar.gz
gentoo-be0aafde743046bdfac23126b7f264589cf4bc18.tar.bz2
gentoo-be0aafde743046bdfac23126b7f264589cf4bc18.zip
sys-fs/ntfs3g: add 'fuse' USE flag
This allows libntfs-3g and ntfsprogs to be installed without the FUSE driver. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/metadata.xml3
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2021.8.22-r3.ebuild (renamed from sys-fs/ntfs3g/ntfs3g-2021.8.22-r2.ebuild)21
2 files changed, 14 insertions, 10 deletions
diff --git a/sys-fs/ntfs3g/metadata.xml b/sys-fs/ntfs3g/metadata.xml
index fd2cd929283c..910a26c2caf5 100644
--- a/sys-fs/ntfs3g/metadata.xml
+++ b/sys-fs/ntfs3g/metadata.xml
@@ -16,9 +16,10 @@
file ownership, access right.
</longdescription>
<use>
+ <flag name="fuse">Enable ntfs-3g FUSE driver</flag>
<flag name="mount-ntfs">Install mount.ntfs symlink</flag>
<flag name="ntfsdecrypt">Build and install the ntfsdecrypt application.</flag>
- <flag name="ntfsprogs">Include internal version of ntfsprogs.</flag>
+ <flag name="ntfsprogs">Enable ntfsprogs</flag>
</use>
<upstream>
<bugs-to>http://tuxera.com/forum/</bugs-to>
diff --git a/sys-fs/ntfs3g/ntfs3g-2021.8.22-r2.ebuild b/sys-fs/ntfs3g/ntfs3g-2021.8.22-r3.ebuild
index fa4b403451ea..1b89073cd283 100644
--- a/sys-fs/ntfs3g/ntfs3g-2021.8.22-r2.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2021.8.22-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 2006-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,7 +16,7 @@ LICENSE="GPL-2"
# The subslot matches the SONAME major #.
SLOT="0/89"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="acl debug +mount-ntfs ntfsdecrypt +ntfsprogs static-libs suid xattr"
+IUSE="acl debug +fuse +mount-ntfs ntfsdecrypt +ntfsprogs static-libs suid xattr"
RDEPEND="
sys-apps/util-linux:0=
@@ -52,6 +52,7 @@ src_configure() {
--disable-ldconfig
--enable-extras
$(use_enable debug)
+ $(use_enable fuse ntfs-3g)
$(use_enable acl posix-acls)
$(use_enable xattr xattr-mappings)
$(use_enable ntfsdecrypt crypto)
@@ -75,13 +76,15 @@ src_configure() {
src_install() {
default
- if use suid; then
- fperms u+s /usr/bin/ntfs-3g
- fi
- if use mount-ntfs; then
- dosym mount.ntfs-3g /sbin/mount.ntfs
+ if use fuse; then
+ # Plugins directory
+ keepdir "/usr/$(get_libdir)/ntfs-3g"
+ if use suid; then
+ fperms u+s /usr/bin/ntfs-3g
+ fi
+ if use mount-ntfs; then
+ dosym mount.ntfs-3g /sbin/mount.ntfs
+ fi
fi
find "${ED}" -name '*.la' -type f -delete || die
- # https://bugs.gentoo.org/760780
- keepdir "/usr/$(get_libdir)/ntfs-3g"
}