summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-10-14 10:06:01 -0500
committerBen Kohler <bkohler@gentoo.org>2019-10-14 10:07:49 -0500
commitc8d52e5c7308ae8eb0b87cc373289b0385d896a9 (patch)
treeb759af571128f74dfcccb22b683644a4be7d8819 /sys-fs
parentsys-kernel/genkernel: bump to v4.0.0_beta20 (diff)
downloadgentoo-c8d52e5c7308ae8eb0b87cc373289b0385d896a9.tar.gz
gentoo-c8d52e5c7308ae8eb0b87cc373289b0385d896a9.tar.bz2
gentoo-c8d52e5c7308ae8eb0b87cc373289b0385d896a9.zip
sys-fs/ecryptfs-utils: bump to new snapshot
Version bump bug has been open over 3 years with no known blocking problems. I'm doing a non-maintainer bump to fix several outstanding issues. Bug: https://bugs.gentoo.org/572500 Closes: https://bugs.gentoo.org/595264 Closes: https://bugs.gentoo.org/697700 Closes: https://bugs.gentoo.org/694104 Closes: https://github.com/gentoo/gentoo/pull/12464 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ecryptfs-utils/Manifest1
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-111_p20170609.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-fs/ecryptfs-utils/Manifest b/sys-fs/ecryptfs-utils/Manifest
index fa8c47275d2b..0b38459deb45 100644
--- a/sys-fs/ecryptfs-utils/Manifest
+++ b/sys-fs/ecryptfs-utils/Manifest
@@ -1 +1,2 @@
+DIST ecryptfs-utils-111_p20170609.tar.gz 1433722 BLAKE2B eeb8840e0b369d2eb420e7853629086cbf430daed2dbf3ed620f5c2489de711c9d8dc5c2b555db5d09b968df6d07da19b93ca46add3b7987d3ff1ad9f06adc69 SHA512 4788a35d68bbb6b769803754adad14d063564e6285edcec4d68df076e96c61550ab6487a1b84498e24e3f56f8c9fda6eb63a66d469d3e654834357c5e2b4c781
DIST ecryptfs-utils_108.orig.tar.gz 659465 BLAKE2B a4497470e1aeb3122da1c612a4bb9a32bbae960fad165b5d30543ccaf5682d877927b881956e109c2910eb46e456470ffc0f8fc1f3766f6767741d28d05dc802 SHA512 856d8fac587921f1b5cd0b4ff269c7db8941b6b183506c5bc2e640a77994293f3e09ecfaef94f12c00f2378e756ecec252d3f59eebbabb4229105f8be87653ba
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-111_p20170609.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-111_p20170609.ebuild
new file mode 100644
index 000000000000..f132fa8f68d1
--- /dev/null
+++ b/sys-fs/ecryptfs-utils/ecryptfs-utils-111_p20170609.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit flag-o-matic pam python-single-r1 linux-info autotools
+
+DESCRIPTION="eCryptfs userspace utilities"
+HOMEPAGE="https://launchpad.net/ecryptfs"
+SRC_URI="https://bazaar.launchpad.net/~ecryptfs/ecryptfs/trunk/tarball/894 -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc gpg gtk nls openssl pam pkcs11 python suid tpm"
+
+RDEPEND=">=sys-apps/keyutils-1.5.11-r1:=
+ >=dev-libs/libgcrypt-1.2.0:0
+ dev-libs/nss
+ gpg? ( app-crypt/gpgme )
+ gtk? ( x11-libs/gtk+:2 )
+ openssl? ( >=dev-libs/openssl-0.9.7:= )
+ pam? ( sys-libs/pam )
+ pkcs11? (
+ >=dev-libs/openssl-0.9.7:=
+ >=dev-libs/pkcs11-helper-1.04
+ )
+ python? ( ${PYTHON_DEPS} )
+ tpm? ( app-crypt/trousers )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.41.0
+ python? ( dev-lang/swig )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+
+ CONFIG_CHECK="~ECRYPT_FS"
+ linux-info_pkg_setup
+}
+
+src_unpack() {
+ mkdir -p "${S}" || die
+ tar -xf "${DISTDIR}/${P}.tar.gz" --strip-components=3 -C "${S}"
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -D_FILE_OFFSET_BITS=64
+
+ econf \
+ --enable-nss \
+ --with-pamdir=$(getpam_mod_dir) \
+ $(use_enable doc docs) \
+ $(use_enable gpg) \
+ $(use_enable gtk gui) \
+ $(use_enable nls) \
+ $(use_enable openssl) \
+ $(use_enable pam) \
+ $(use_enable pkcs11 pkcs11-helper) \
+ $(use_enable python pywrap) \
+ $(use_enable tpm tspi)
+}
+
+src_install(){
+ emake DESTDIR="${D}" install
+
+ if use python; then
+ echo "ecryptfs-utils" > "${D}$(python_get_sitedir)/ecryptfs-utils.pth" || die
+ fi
+
+ use suid && fperms u+s /sbin/mount.ecryptfs_private
+
+ find "${ED}" -name '*.la' -exec rm -f '{}' + || die
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there are any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}