summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMatthias Gerstner <Matthias.Gerstner@nefkom.net>2017-10-22 23:11:52 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-11-06 00:07:41 +0100
commitd2ceae7ce6813f5ab0d7bd18127061b51faec240 (patch)
treee250d29e2ee87ef25c52d23a59966c9339aa9d2b /sys-fs
parentdev-php/maxmind-db-reader: new PHP interface to the MaxMind databases. (diff)
downloadgentoo-d2ceae7ce6813f5ab0d7bd18127061b51faec240.tar.gz
gentoo-d2ceae7ce6813f5ab0d7bd18127061b51faec240.tar.bz2
gentoo-d2ceae7ce6813f5ab0d7bd18127061b51faec240.zip
sys-fs/xmwfs: new ebuild.
xmwfs is a X11 Window-Manager file system based on FUSE. Closes: https://github.com/gentoo/gentoo/pull/6020 Closes: https://bugs.gentoo.org/634810
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xwmfs/Manifest1
-rw-r--r--sys-fs/xwmfs/metadata.xml34
-rw-r--r--sys-fs/xwmfs/xwmfs-0.81.ebuild20
3 files changed, 55 insertions, 0 deletions
diff --git a/sys-fs/xwmfs/Manifest b/sys-fs/xwmfs/Manifest
new file mode 100644
index 000000000000..805b0d3fc67e
--- /dev/null
+++ b/sys-fs/xwmfs/Manifest
@@ -0,0 +1 @@
+DIST xwmfs-0.81.tar.gz 192750 SHA256 490f9186681dfce8b6576f81130cfce6f51fd5d5a70a8554637946c5bf831c6a SHA512 7b11e4f38654144467b128fcdd84082f3d5f16817d6b40285a0726165bb16c34ea076981d5866c952ce74e9a21b6b2dbcf53ed96631fd13d7b263a55cb6a577a WHIRLPOOL 0ee5a4fff41ba2330dc777a89e686e3e8f954f61c53c265a7208856cbec4cc01596bedb23819e8e222f31a31a1ac34bf3cf0c2b934c117718dfb8894a8e86b5c
diff --git a/sys-fs/xwmfs/metadata.xml b/sys-fs/xwmfs/metadata.xml
new file mode 100644
index 000000000000..8b58b472e953
--- /dev/null
+++ b/sys-fs/xwmfs/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>matthias.gerstner@nefkom.net</email>
+ <name>Matthias Gerstner</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is xwmfs (X window manager file system), a userspace file system based on
+ fuse that allows interaction with an EWMH compliant X11 window manager
+ via files.
+
+ Some of its features are:
+
+ - newly appearing and disappearing windows in the X server are recognized and
+ the file system is updated in an event based manner
+ - new values for properties of window manager and windows will be reflected in
+ the file system in an event based manner
+ - properties of windows and window manager can be changed via writing to files
+ in the file system
+ - some X operations are accessible via control files in the file system
+
+ The file system can be used for easily implementing scripts that operate on
+ the window manager and windows (for example identifying specific windows,
+ rename a window, move it around and so on).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gestner-hub/xwmfs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/xwmfs/xwmfs-0.81.ebuild b/sys-fs/xwmfs/xwmfs-0.81.ebuild
new file mode 100644
index 000000000000..aa134c2864b1
--- /dev/null
+++ b/sys-fs/xwmfs/xwmfs-0.81.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="FUSE-based X11 Window-Manager file system"
+HOMEPAGE="https://github.com/gerstner-hub/xwmfs"
+SRC_URI="https://github.com/gerstner-hub/${PN}/releases/download/v${PV}/${P}-dist.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~arm"
+SLOT="0"
+
+RDEPEND="
+ sys-fs/fuse:=
+ >=x11-libs/libX11-1.6.5"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"