summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-03 20:13:52 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-03 20:14:55 -0700
commitddfed3ec49867b804baa6af98220ec437e8d117a (patch)
tree17d70a8d67c249db426aa146c324274d885afcdd /sys-fs
parentsci-visualization/paraview: remove r1 (diff)
downloadgentoo-ddfed3ec49867b804baa6af98220ec437e8d117a.tar.gz
gentoo-ddfed3ec49867b804baa6af98220ec437e8d117a.tar.bz2
gentoo-ddfed3ec49867b804baa6af98220ec437e8d117a.zip
sys-fs/squashfs-tools-ng: Fix build failure
Closes: https://bugs.gentoo.org/715790 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools-ng/files/squashfs-tools-ng-0.9-Fix-missing-header-without-LZO.patch32
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.9.ebuild4
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/files/squashfs-tools-ng-0.9-Fix-missing-header-without-LZO.patch b/sys-fs/squashfs-tools-ng/files/squashfs-tools-ng-0.9-Fix-missing-header-without-LZO.patch
new file mode 100644
index 000000000000..cd32661e0092
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/files/squashfs-tools-ng-0.9-Fix-missing-header-without-LZO.patch
@@ -0,0 +1,32 @@
+From b3f2636f44eea1a8b6fbf892d2daa611cff9d4af Mon Sep 17 00:00:00 2001
+From: Alyssa Ross <hi@alyssa.is>
+Date: Wed, 1 Apr 2020 14:30:51 +0000
+Subject: [PATCH] Fix missing header without LZO
+
+lib/common/compress.c: In function 'compressor_get_default':
+lib/common/compress.c:39:2: warning: implicit declaration of function 'assert' [-Wimplicit-function-declaration]
+ 39 | assert(0);
+ | ^~~~~~
+lib/common/compress.c:8:1: note: 'assert' is defined in header '<assert.h>'; did you forget to '#include <assert.h>'?
+ 7 | #include "common.h"
+ +++ |+#include <assert.h>
+ 8 |
+---
+ lib/common/compress.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/lib/common/compress.c b/lib/common/compress.c
+index ea7b71f..f16f080 100644
+--- a/lib/common/compress.c
++++ b/lib/common/compress.c
+@@ -5,6 +5,7 @@
+ * Copyright (C) 2019 David Oberhollenzer <goliath@infraroot.at>
+ */
+ #include "common.h"
++#include <assert.h>
+
+ static int cmp_ids[] = {
+ SQFS_COMP_XZ,
+--
+2.24.1
+
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.9.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.9.ebuild
index 79c567828ddc..366d46b0bdb0 100644
--- a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.9.ebuild
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.9.ebuild
@@ -27,6 +27,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-Fix-missing-header-without-LZO.patch
+)
+
src_prepare() {
default
[[ ${PV} == "9999" ]] && eautoreconf