summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-01-10 13:20:34 -0500
committerMike Gilbert <floppym@gentoo.org>2018-01-10 13:31:46 -0500
commite248b7af8903fdb47cd11c203d46f8eded6023c3 (patch)
tree8457861f1e6e168486b42e0682691f76a86967ef /sys-fs
parentdev-perl/Safe-Isa: Bump to version 1.0.8 (diff)
downloadgentoo-e248b7af8903fdb47cd11c203d46f8eded6023c3.tar.gz
gentoo-e248b7af8903fdb47cd11c203d46f8eded6023c3.tar.bz2
gentoo-e248b7af8903fdb47cd11c203d46f8eded6023c3.zip
sys-fs/udev: fix 233 build with glibc-2.26
Package-Manager: Portage-2.3.19_p3, Repoman-2.3.6_p37
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/files/233-fix-includes.patch38
-rw-r--r--sys-fs/udev/udev-233.ebuild3
2 files changed, 40 insertions, 1 deletions
diff --git a/sys-fs/udev/files/233-fix-includes.patch b/sys-fs/udev/files/233-fix-includes.patch
new file mode 100644
index 000000000000..44b06214f89d
--- /dev/null
+++ b/sys-fs/udev/files/233-fix-includes.patch
@@ -0,0 +1,38 @@
+From 284d1cd0a12cad96a5ea61d1afb0dd677dbd147e Mon Sep 17 00:00:00 2001
+From: Matija Skala <mskala@gmx.com>
+Date: Wed, 15 Mar 2017 13:21:10 +0100
+Subject: [PATCH] fix includes
+
+linux/sockios.h is needed for the SIOCGSTAMPNS macro
+
+xlocale.h is included indirectly in glibc and doesn't even exist in
+other libcs
+---
+ src/basic/parse-util.c | 1 -
+ src/libsystemd-network/sd-lldp.c | 1 +
+ 2 files changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/basic/parse-util.c b/src/basic/parse-util.c
+index 6e58ced6f5..d86700736d 100644
+--- a/src/basic/parse-util.c
++++ b/src/basic/parse-util.c
+@@ -23,7 +23,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <xlocale.h>
+
+ #include "alloc-util.h"
+ #include "extract-word.h"
+diff --git a/src/libsystemd-network/sd-lldp.c b/src/libsystemd-network/sd-lldp.c
+index 0702241506..39ddb2461a 100644
+--- a/src/libsystemd-network/sd-lldp.c
++++ b/src/libsystemd-network/sd-lldp.c
+@@ -19,6 +19,7 @@
+ ***/
+
+ #include <arpa/inet.h>
++#include <linux/sockios.h>
+
+ #include "sd-lldp.h"
+
diff --git a/sys-fs/udev/udev-233.ebuild b/sys-fs/udev/udev-233.ebuild
index c42ecc2c0be4..33ba3ae76f47 100644
--- a/sys-fs/udev/udev-233.ebuild
+++ b/sys-fs/udev/udev-233.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -57,6 +57,7 @@ S=${WORKDIR}/systemd-${PV}
PATCHES=(
"${FILESDIR}"/233-format-warnings.patch
+ "${FILESDIR}"/233-fix-includes.patch
)
check_default_rules() {